Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-10-24 09:44:59

tuxolero
Member
Registered: 2013-02-10
Posts: 55

[SOLVED] Since yesterday's update, I can only "print to file"

Hi,

I'm using XFCE on Arch Linux. Since yesterday's updates, I can only "print to file" from some applications (firefox, document viewer). Others work (LibreOffice).

Something is curious about this issue: The document viewer was not updated, so it must be something in the environment.

These packages were upgraded (omitted scripts output, like mkinitramfs):

[2016-10-23 20:32] [ALPM] transaction started
[2016-10-23 20:32] [ALPM] removed lib32-libdbus (1.10.10-3)
[2016-10-23 20:32] [ALPM] removed lib32-elfutils (0.167-1)
[2016-10-23 20:32] [ALPM] upgraded tzdata (2016g-1 -> 2016h-1)
[2016-10-23 20:32] [ALPM] upgraded glib2 (2.48.2-1 -> 2.50.1-1)
[2016-10-23 20:32] [ALPM] upgraded libpng (1.6.25-1 -> 1.6.26-2)
[2016-10-23 20:32] [ALPM] upgraded jasper (1.900.1-15 -> 1.900.5-1)
[2016-10-23 20:32] [ALPM] upgraded gdk-pixbuf2 (2.34.0-2 -> 2.36.0+2+ga7c869a-1)
[2016-10-23 20:32] [ALPM] upgraded gtk-update-icon-cache (3.20.9-1 -> 3.22.1+67+gffb1ac5-1)
[2016-10-23 20:32] [ALPM] upgraded harfbuzz (1.3.1-1 -> 1.3.2-1)
[2016-10-23 20:32] [ALPM] upgraded libsystemd (231-3 -> 231-4)
[2016-10-23 20:32] [ALPM] upgraded dbus (1.10.10-3 -> 1.10.12-1)
[2016-10-23 20:32] [ALPM] upgraded systemd (231-3 -> 231-4)
[2016-10-23 20:32] [ALPM] upgraded libedit (20160618_3.1-1 -> 20160903_3.1-1)
[2016-10-23 20:32] [ALPM] upgraded mesa (12.0.3-2 -> 12.0.3-3)
[2016-10-23 20:32] [ALPM] upgraded mesa-libgl (12.0.3-2 -> 12.0.3-3)
[2016-10-23 20:32] [ALPM] upgraded adwaita-icon-theme (3.20-2 -> 3.22.0-1)
[2016-10-23 20:32] [ALPM] upgraded libxi (1.7.7-1 -> 1.7.7-2)
[2016-10-23 20:32] [ALPM] upgraded at-spi2-core (2.20.2-1 -> 2.22.0-1)
[2016-10-23 20:32] [ALPM] upgraded atk (2.20.0-1 -> 2.22+1+gd57f97d-1)
[2016-10-23 20:32] [ALPM] upgraded at-spi2-atk (2.20.1-2 -> 2.22.0-1)
[2016-10-23 20:32] [ALPM] upgraded geoip-database (20160907-1 -> 20161004-1)
[2016-10-23 20:32] [ALPM] upgraded bind-tools (9.10.4.P3-1 -> 9.11.0-2)
[2016-10-23 20:32] [ALPM] upgraded bridge-utils (1.5-2 -> 1.6-1)
[2016-10-23 20:32] [ALPM] upgraded ca-certificates-mozilla (3.26-1 -> 3.27.1-1)
[2016-10-23 20:32] [ALPM] upgraded nspr (4.12-1 -> 4.13-1)
[2016-10-23 20:32] [ALPM] upgraded sqlite (3.14.2-1 -> 3.15.0-1)
[2016-10-23 20:32] [ALPM] upgraded nss (3.26-1 -> 3.27.1-1)
[2016-10-23 20:32] [ALPM] installed re2 (20160901-1)
[2016-10-23 20:32] [ALPM] upgraded harfbuzz-icu (1.3.1-1 -> 1.3.2-1)
[2016-10-23 20:32] [ALPM] upgraded gnutls (3.4.15-1 -> 3.4.16-1)
[2016-10-23 20:32] [ALPM] upgraded chromium (53.0.2785.143-1 -> 54.0.2840.71-1)
[2016-10-23 20:32] [ALPM] upgraded json-glib (1.2.2-1 -> 1.2.2+4+gd725fb5-1)
[2016-10-23 20:32] [ALPM] upgraded gtk3 (3.20.9-1 -> 3.22.1+67+gffb1ac5-1)
[2016-10-23 20:32] [ALPM] upgraded clutter (1.26.0-1 -> 1.26.0+24+g79da526-1)
[2016-10-23 20:32] [ALPM] upgraded clutter-gtk (1.8.0-1 -> 1.8.2-1)
[2016-10-23 20:32] [ALPM] upgraded jsoncpp (1.7.6-1 -> 1.7.7-1)
[2016-10-23 20:32] [ALPM] upgraded cmake (3.6.2-1 -> 3.6.2-2)
[2016-10-23 20:32] [ALPM] upgraded colord (1.3.2-2 -> 1.3.3-1)
[2016-10-23 20:32] [ALPM] upgraded iproute2 (4.7.0-1 -> 4.8.0-1)
[2016-10-23 20:32] [ALPM] upgraded docker (1:1.12.1-1 -> 1:1.12.2-1)
[2016-10-23 20:32] [ALPM] upgraded libsamplerate (0.1.8-3 -> 0.1.9-1)
[2016-10-23 20:32] [ALPM] upgraded jack (0.124.1-6 -> 0.125.0-1)
[2016-10-23 20:32] [ALPM] upgraded libass (0.13.3-1 -> 0.13.4-1)
[2016-10-23 20:32] [ALPM] upgraded firefox (49.0.1-1 -> 49.0.2-1)
[2016-10-23 20:32] [ALPM] upgraded firefox-i18n-de (49.0.1-1 -> 49.0.2-1)
[2016-10-23 20:32] [ALPM] upgraded gcr (3.20.0-2 -> 3.20.0+11+g8322f27-1)
[2016-10-23 20:32] [ALPM] upgraded gdal (2.1.1-1 -> 2.1.1-2)
[2016-10-23 20:32] [ALPM] upgraded git (2.10.0-1 -> 2.10.1-1)
[2016-10-23 20:32] [ALPM] upgraded gsettings-desktop-schemas (3.21.4-1 -> 3.22.0+1+g6f52ab5-1)
[2016-10-23 20:32] [ALPM] upgraded glib-networking (2.48.2-1 -> 2.50.0-1)
[2016-10-23 20:32] [ALPM] upgraded libsigc++ (2.8.0-1 -> 2.10.0-1)
[2016-10-23 20:32] [ALPM] upgraded glibmm (2.48.1-1 -> 2.50.0-1)
[2016-10-23 20:32] [ALPM] upgraded gnome-desktop (1:3.20.2-1 -> 1:3.22.1-1)
[2016-10-23 20:32] [ALPM] upgraded gnome-keyring (1:3.20.0-2 -> 1:3.20.0+16+gbf8aa97-1)
[2016-10-23 20:32] [ALPM] upgraded gnome-mahjongg (3.20.0-2 -> 3.22.0+1+g55799c1-1)
[2016-10-23 20:32] [ALPM] upgraded gnome-themes-standard (3.20.2-1 -> 3.22.2-1)
[2016-10-23 20:32] [ALPM] upgraded gobject-introspection-runtime (1.48.0-1 -> 1.50.0+1+gb8d92b0-2)
[2016-10-23 20:32] [ALPM] upgraded python-pyparsing (2.1.9-1 -> 2.1.10-1)
[2016-10-23 20:32] [ALPM] upgraded python-setuptools (1:28.1.0-1 -> 1:28.6.1-1)
[2016-10-23 20:32] [ALPM] upgraded gobject-introspection (1.48.0-1 -> 1.50.0+1+gb8d92b0-2)
[2016-10-23 20:32] [ALPM] upgraded gparted (0.26.1-1 -> 0.27.0-1)
[2016-10-23 20:32] [ALPM] upgraded grep (2.25-2 -> 2.26-1)
[2016-10-23 20:32] [ALPM] upgraded grub (1:2.02.beta3-3 -> 1:2.02.beta3-4)
[2016-10-23 20:32] [ALPM] upgraded gstreamer (1.8.3-1 -> 1.9.90+8+g6d0d350-1)
[2016-10-23 20:32] [ALPM] upgraded gst-plugins-base-libs (1.8.3-1 -> 1.9.90+12+g667931e-1)
[2016-10-23 20:32] [ALPM] upgraded gst-libav (1.8.3-1 -> 1.9.90+2+g108b08c-1)
[2016-10-23 20:32] [ALPM] upgraded gst-plugins-bad (1.8.3-2 -> 1.9.90+20+g7dd42ae-1)
[2016-10-23 20:32] [ALPM] upgraded gst-plugins-base (1.8.3-1 -> 1.9.90+12+g667931e-1)
[2016-10-23 20:32] [ALPM] upgraded libsoup (2.54.1-1 -> 2.56.0-1)
[2016-10-23 20:32] [ALPM] upgraded gst-plugins-good (1.8.3-1 -> 1.9.90+8+g6542edd-1)
[2016-10-23 20:32] [ALPM] upgraded gst-plugins-ugly (1.8.3-1 -> 1.9.90+2+g07e5039-1)
[2016-10-23 20:32] [ALPM] upgraded gtk-vnc (0.6.0-1 -> 0.6.0+1+gf966e7b-1)
[2016-10-23 20:32] [ALPM] upgraded gtkmm3 (3.20.1-1 -> 3.22.0-1)
[2016-10-23 20:32] [ALPM] upgraded gtksourceview3 (3.20.4-1 -> 3.22.0+4+g87c38b3-1)
[2016-10-23 20:32] [ALPM] upgraded guile (2.0.12-1 -> 2.0.13-1)
[2016-10-23 20:32] [ALPM] upgraded gvfs (1.28.3-1 -> 1.30.1.1-1)
[2016-10-23 20:32] [ALPM] upgraded imagemagick (6.9.6.0-1 -> 6.9.6.2-1)
[2016-10-23 20:32] [ALPM] upgraded jansson (2.8-1 -> 2.9-1)
[2016-10-23 20:32] [ALPM] upgraded jre8-openjdk-headless (8.u102-1 -> 8.u112-1)
[2016-10-23 20:32] [ALPM] upgraded jre8-openjdk (8.u102-1 -> 8.u112-1)
[2016-10-23 20:32] [ALPM] upgraded jdk8-openjdk (8.u102-1 -> 8.u112-1)
[2016-10-23 20:33] [ALPM] upgraded kdelibs (4.14.24-2 -> 4.14.25-1)
[2016-10-23 20:33] [ALPM] installed lib32-libelf (0.167-1)
[2016-10-23 20:33] [ALPM] installed lib32-dbus (1.10.12-1)
[2016-10-23 20:33] [ALPM] upgraded lib32-glib2 (2.48.1-1 -> 2.50.1-2)
[2016-10-23 20:33] [ALPM] upgraded lib32-mesa (12.0.3-2 -> 12.0.3-4)
[2016-10-23 20:33] [ALPM] upgraded lib32-mesa-libgl (12.0.3-2 -> 12.0.3-4)
[2016-10-23 20:33] [ALPM] upgraded libgtop (2.34.0-2 -> 2.34.1-1)
[2016-10-23 20:33] [ALPM] upgraded libgxps (0.2.4-1 -> 0.2.4+12+g4709da9-1)
[2016-10-23 20:33] [ALPM] upgraded libnautilus-extension (3.20.3-1 -> 3.22.1-1)
[2016-10-23 20:33] [ALPM] upgraded libnotify (0.7.6-2 -> 0.7.7-1)
[2016-10-23 20:33] [ALPM] upgraded libtracker-sparql (1.8.0-3 -> 1.10.1+3+g0e839d0-1)
[2016-10-23 20:33] [ALPM] upgraded linux-firmware (20160915.c4c07a8-1 -> 20161005.9c71af9-1)
[2016-10-23 20:33] [ALPM] upgraded linux (4.7.6-1 -> 4.8.4-1)
[2016-10-23 20:33] [ALPM] upgraded linux-headers (4.7.6-1 -> 4.8.4-1)
[2016-10-23 20:33] [ALPM] upgraded linux-lts (4.4.23-1 -> 4.4.27-1)
[2016-10-23 20:33] [ALPM] upgraded linux-lts-headers (4.4.23-1 -> 4.4.27-1)
[2016-10-23 20:33] [ALPM] upgraded man-pages (4.07-1 -> 4.08-1)
[2016-10-23 20:33] [ALPM] installed gnome-autoar (0.1.1+1+g8d75c44-1)
[2016-10-23 20:33] [ALPM] upgraded nautilus (3.20.3-1 -> 3.22.1-1)
[2016-10-23 20:33] [ALPM] upgraded nodejs (6.7.0-1 -> 6.9.1-1)
[2016-10-23 20:33] [ALPM] upgraded npm (3.10.8-1 -> 3.10.9-1)
[2016-10-23 20:33] [ALPM] upgraded pygobject-devel (3.20.1-1 -> 3.22.0-1)
[2016-10-23 20:33] [ALPM] upgraded python-gobject (3.20.1-1 -> 3.22.0-1)
[2016-10-23 20:33] [ALPM] upgraded python2-gobject (3.20.1-1 -> 3.22.0-1)
[2016-10-23 20:33] [ALPM] upgraded python2-pytz (2016.6.1-1 -> 2016.7-1)
[2016-10-23 20:33] [ALPM] upgraded python2-pyparsing (2.1.9-1 -> 2.1.10-1)
[2016-10-23 20:33] [ALPM] upgraded python2-matplotlib (1.5.2-2 -> 1.5.3-1)
[2016-10-23 20:33] [ALPM] upgraded python2-setuptools (1:28.1.0-1 -> 1:28.6.1-1)
[2016-10-23 20:33] [ALPM] upgraded python2-pyopenssl (16.1.0-1 -> 16.2.0-1)
[2016-10-23 20:33] [ALPM] upgraded ristretto (0.8.0-2 -> 0.8.1-1)
[2016-10-23 20:33] [ALPM] upgraded s-nail (14.8.10-1 -> 14.8.12-1)
[2016-10-23 20:33] [ALPM] upgraded scons (2.4.1-1 -> 2.5.0-1)
[2016-10-23 20:33] [ALPM] upgraded sdl2 (2.0.4-2 -> 2.0.5-1)
[2016-10-23 20:33] [ALPM] upgraded seahorse (3.20.0-2 -> 3.20.0+44+ga1474bb-1)
[2016-10-23 20:33] [ALPM] upgraded serf (1.3.8-2 -> 1.3.9-1)
[2016-10-23 20:33] [ALPM] upgraded simple-scan (3.20.0-2 -> 3.22.0.1-1)
[2016-10-23 20:33] [ALPM] upgraded webkit2gtk (2.12.5-1 -> 2.14.1-1)
[2016-10-23 20:33] [ALPM] upgraded zenity (3.20.0-1 -> 3.22.0+1+gcd1647c-1)
[2016-10-23 20:33] [ALPM] upgraded sudo (1.8.18-1 -> 1.8.18.p1-1)
[2016-10-23 20:33] [ALPM] upgraded systemd-sysvcompat (231-3 -> 231-4)
[2016-10-23 20:33] [ALPM] upgraded virtualbox-host-dkms (5.1.6-1 -> 5.1.8-1)
[2016-10-23 20:33] [ALPM] upgraded virtualbox (5.1.6-1 -> 5.1.8-1)
[2016-10-23 20:34] [ALPM] upgraded virtualbox-guest-iso (5.1.6-1 -> 5.1.8-1)
[2016-10-23 20:34] [ALPM] upgraded vte-common (0.44.2-1 -> 0.46.0+5+g398a3f8-1)
[2016-10-23 20:34] [ALPM] installed pcre2 (10.22-1)
[2016-10-23 20:34] [ALPM] upgraded vte3 (0.44.2-1 -> 0.46.0+5+g398a3f8-1)
[2016-10-23 20:34] [ALPM] upgraded vtk (7.0.0-2 -> 7.0.0-3)
[2016-10-23 20:34] [ALPM] upgraded vtk6 (6.3.0-4 -> 6.3.0-5)
[2016-10-23 20:34] [ALPM] upgraded xfce4-terminal (0.6.3-3 -> 0.8.0-2)
[2016-10-23 20:34] [ALPM] upgraded xscreensaver (5.35-1 -> 5.36-1)
[2016-10-23 20:34] [ALPM] upgraded xterm (326-1 -> 327-1)
[2016-10-23 20:34] [ALPM] transaction completed

My printer is there in "Settings -> Printer Settings" as well as in the CUPS status page http://localhost:631/printers/, and i can also print the thest page.

How can I troubleshoot the non-working applications ?

Thanks and Regards,
Tuxolero

Last edited by tuxolero (2016-10-27 21:38:33)

Offline

#2 2016-10-24 10:19:56

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: [SOLVED] Since yesterday's update, I can only "print to file"

Since gtk 3.22, gtk3-print-backends is required for printing from gtk3 apps.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2016-10-24 11:55:58

tuxolero
Member
Registered: 2013-02-10
Posts: 55

Re: [SOLVED] Since yesterday's update, I can only "print to file"

OK, I'm going to try it ... as soon as it's available.

Currently, all mirrors respond a 404 when trying to retrieve it. But that's a distro problem, of course.

Offline

#4 2016-10-27 21:38:04

tuxolero
Member
Registered: 2013-02-10
Posts: 55

Re: [SOLVED] Since yesterday's update, I can only "print to file"

I just want to let you know it worked after installing gtk3-print-backends.

Offline

#5 2016-12-22 12:41:51

dgavenda
Member
Registered: 2007-06-16
Posts: 10

Re: [SOLVED] Since yesterday's update, I can only "print to file"

I had the same exact problem even after installing gtk3-print-backends.  The trick was I needed to add/delete a printer via CUPS.  I am not sure why that worked but it did.

Offline

#6 2016-12-22 13:35:03

Jerry3904
Member
Registered: 2013-11-09
Posts: 519

Re: [SOLVED] Since yesterday's update, I can only "print to file"

Is this peculiar to Arch?


MX-16 (based on Debian Stable) with Xfce 4.12.

Offline

#7 2016-12-22 15:12:14

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: [SOLVED] Since yesterday's update, I can only "print to file"

Jerry3904 wrote:

Is this peculiar to Arch?

I've only come across it in Arch and I can't find any news of it anywhere - even on the GTK sites. So probably just an Arch thing. It basically removes the print libraries (cups and cloudprint) from the main package and makes it an optional dependency (I guess in case you don't need print capabilities).


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB