Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-01-10 14:28:37

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Parole not inhibiting screensaver

I am running Xubuntu 16.04.01 and using Parole as the default video player. As I'm sure many know, the Parole app allows for a preference to inhibit the screensaver when playing a movie fullscreen. However, I have noticed that it is not doing so on my system, despite the option being set to on within the preferences.
I have tested with an .mp4 video and an .flv video on my computer and had the same result occur on both times. I even tried setting the preference to off just to see if that changed anything, to no avail.
I tested using an HTML5 video (specifically Youtube) at fullscreen, and found no issue there.
Does anyone know how to fix this?

Offline

#2 2017-01-11 03:13:38

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

Are you running on a latpop or a desktop?

Parole seems to use xdg-screensaver to set the suspend status of any given window.

Can you try the following commands to see if they work:

xdg-screensaver activate

...should activate your screensaver.

xdg-screensaver suspend $(xwininfo -name "Parole Media Player" | grep xwininfo | awk '{print $4}')

...with Parole open, should disable screensaver while parole window is active. See if this works.

Another option is to use "Presentation Mode" in xfce4-power-manager's plugin properties.

There are a couple of existing bug reports for this issue in the bug tracker.

EDIT: For the xdg-screensaver option, make sure you have xprop installed.

Last edited by ToZ (2017-01-11 03:15:06)


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-01-11 04:30:11

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Re: Parole not inhibiting screensaver

Running from a laptop. The first command did activate the screensaver, however the second command failed to inhibit the screensaver.
I did consider presentation mode, but I kind of feel like Parole should be a bit more on it's game.

Offline

#4 2017-01-11 14:29:07

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

Can you try this to see if it generates any error messages?

XDG_UTILS_DEBUG_LEVEL=2 xdg-screensaver suspend $(xwininfo -name "Parole Media Player" | grep xwininfo | awk '{print $4}')

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2017-01-11 16:07:28

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

Just doing some investigation, parole seems to use xdg-screensaver to suspend the screensaver. xdg-screensaver doesn't seem to support light-locker.

xdg-screensaver uses xdg-utils to get the DE (for Xubuntu, this returns "xfce"). It then checks for certain other screensavers (of which light-locker is not one of them). In that case, it uses the "xfce" option which in turn runs the screensaver_xscreensaver() function which simply runs "xset s off".

Perhaps the issue is xdg-screensaver not supporting light-locker? As a test, you might consider uninstalling light-locker, installing xscreensaver and seeing if it makes a difference (since xscreensaver is supported)?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#6 2017-01-11 21:03:15

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

One more post. Went deeper down the rabbit hole. It looks like light-locker adds a schema file to make xdg-screensaver see it as a gnome-screensaver and xdg-screensaver then runs the gnome-screensaver code - which are basically dbus-calls to inhibit the screensaver.

I only had access to a xubuntu 17.04 install today and did some testing there, and it works fine. I set the screensaver timeout to 1 minute and watched it kick in. Then I started parole and ran a 10 minute video - the screensaver did not kick in. I then exited parole and the screensaver kicked in one minute later.

I'll test this on a 16.04 install at home tonight.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#7 2017-01-12 23:30:54

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Re: Parole not inhibiting screensaver

Sorry for the absence, but thanks for your continued testing! I will post the output of the code you posted when I get home to my Xubuntu system.
As for uninstalling Light Locker, I'm wary of doing so due to my belief that it might do some underlying damage to my system - a personal rule of mine is that applications that were installed on the distro by default stay right where they are.
Looking forward to the 16.04 test. Also, since you're running  17.04 you've clearly been to the future, would you mind passing on lottery numbers and Super Bowl winners?

Offline

#8 2017-01-13 00:03:59

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

chasbel2112 wrote:

Looking forward to the 16.04 test.

Just tested it on my toshiba laptop and the results are the same. With parole running and the "Disable screensaver when playing movies" option checked in the preferences, the screensaver (light-locker) does not lock the laptop. As soon as I close parole and the timeout timer expires, the system locks.

Also, since you're running  17.04 you've clearly been to the future, would you mind passing on lottery numbers and Super Bowl winners?

It's the zesty daily image which will eventually be 17.04.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#9 2017-01-13 02:25:55

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Re: Parole not inhibiting screensaver

Ah, well it was worth a shot

As to the question a few posts ago, I have the outputs. Without Parole open,

XDG_UTILS_DEBUG_LEVEL=2 xdg-screensaver suspend $(xwininfo -name "Parole Media Player" | grep xwininfo | awk '{print $4}')

outputs

xwininfo: error: No window with name "Parole Media Player" exists!
mv -T available
xdg-screensaver: WindowID argument missing
Try 'xdg-screensaver --help' for more information.

With Parole open it outputs

mv -T available
Running /usr/bin/xprop -id 0x4400007
chas@chas-UX31E:~$ org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Offline

#10 2017-01-13 02:49:33

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

I get the same.
Can you post back all of your parole settings just to confirm:

xfconf-query -c parole -lv

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#11 2017-01-13 03:39:35

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Re: Parole not inhibiting screensaver

chas@chas-UX31E:~$ xfconf-query -c parole -lv
/audio/volume                100
/folders/last-used-media     /home/chas/Videos
/parole/plugins              parole-mpris2.so;/usr/lib/x86_64-linux-gnu/parole-0/parole-notify.so
/playlist/play-opened-files  true
/playlist/remember-playlist  false
/playlist/remove-duplicates  true
/playlist/replace-playlist   true
/playlist/show-playlist      false
/subtitles/font              Sans Bold 20
/video/disable-screensaver   true
/video/videosink             xvimagesink
/window/maximized            false
chas@chas-UX31E:~$ 

Offline

#12 2017-01-13 11:29:30

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

Hmmm. Everything looks fine there. I found this old bug report for 12.04 where they findings were similar to mine above and the issue was fixed. I can't replicate it on any of my systems. Not sure what else I can add. Perhaps you could create a launchpad bug report and see if anyone there has some suggestions.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#13 2017-01-13 12:40:28

chasbel2112
Member
Registered: 2016-11-21
Posts: 15

Re: Parole not inhibiting screensaver

I did notice that Light Locker settings was not installed in my system. Upon installing it I noticed that selecting it on the Whisker Menu results in no action. Running from terminal outputs the following:

chas@chas-UX31E:~$ light-locker-settings Traceback (most recent call last): File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 29, in <module> from gi.repository import Gtk, GLib, Gio ImportError: No module named gi.repository chas@chas-UX31E:~$

Could this be contributing?

Offline

#14 2017-01-13 23:53:37

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,590

Re: Parole not inhibiting screensaver

Its not installed on mine either, so its probably not the cause of the problem.

If you have the live CD/USB for 16.04, try booting with that to see if the parole heartbeat functionality works.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB