Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-03-07 00:41:01

caochun
Member
Registered: 2017-03-04
Posts: 4

Whereis libxfce4panel-2.0

hello

xfce4.12
centos7 32 bit

I am currently trying to compile xfce4-pulseaudio-plugin-0.2.4. Here's my output:

checking for pkg-config... (cached) /bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libxfce4panel-2.0 >= 4.11.0... not found
*** The required package libxfce4panel-2.0 was not found on your system.
*** Please install libxfce4panel-2.0 (atleast version 4.11.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
[root@localhost xfce4-pulseaudio-plugin-0.2.4]#

Offline

#2 2017-03-07 02:24:50

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,589

Re: Whereis libxfce4panel-2.0

Look for a libxfce4-panel or an xfce4-panel-devel package (something like that). It will have the xfce4-panel development libraries and support files that the plugin needs to build.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-03-07 05:57:38

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 410
Website

Re: Whereis libxfce4panel-2.0

Is there a reason you are building Xfce yourself rather than installing from the EPEL repos?

Offline

#4 2017-03-07 13:16:24

caochun
Member
Registered: 2017-03-04
Posts: 4

Re: Whereis libxfce4panel-2.0

Thanks ToZ and ozjd.

Sorry, I can't fixing it.
I was downloaded the Xfce 4.12.0 tarball and every packages were installed successfully. It works pretty fast.
If uninstall the xfce4-panel-4.12.0.tar.bz2, The display message reads:<<libxfce4panel-1.0 was not found>> when compile the xfce4-pulseaudio-plugin or xfce4-mixer, else the display message reads:<<libxfce4panel-2.0 was not found>>.

Offline

Board footer

Powered by FluxBB