Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-08-17 22:23:46

bullgod
Member
Registered: 2017-08-14
Posts: 2

Disable root window/background

How do I disable the root window/background.

I used to do this by removing xfdesktop from the session.
But since a upgrade this is no longer listed, so can't be removed.

Many thanks.

Offline

#2 2017-08-18 00:28:42

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,662

Re: Disable root window/background

Hello and welcome.

I used to do this by removing xfdesktop from the session.
But since a upgrade this is no longer listed, so can't be removed.

You should probably create a bug report for this.

One way would be to override the xfdesktop executable. With root privileges, create the file /usr/local/bin/xfdesktop with the following content:

#!/bin/bash

exit 0

...and make the file executable. Then on the next login, it will run this file as xfdesktop, which does nothing.

Offline

#3 2017-08-19 08:05:32

bullgod
Member
Registered: 2017-08-14
Posts: 2

Re: Disable root window/background

The above solution does not work.

Is there configuration setting that can disable the drawing of the background?

Last edited by bullgod (2017-08-19 09:14:40)

Offline

#4 2017-08-19 10:39:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,662

Re: Disable root window/background

bullgod wrote:

The above solution does not work.

As a sanity check, can you post the contents of the file /usr/local/bin/xfdesktop as well as the results of:

ls -l /usr/local/bin/xfdesktop

Is there configuration setting that can disable the drawing of the background?

Not really. But you could also change the background to just display a solid colour, say black. That should give the same effect.

Offline

Board footer

Powered by FluxBB