Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-02-21 12:04:27

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Inhibiting the panel ? (SOLVED)

In the same vein as my recent post on preventing the desktop menu from appearing when  right-clicking on the desktop, is there a way to have no panel ?

( The plan is for boxes in self-service in a library, that will have a reduced number of applications launched from desktop-launcher icons, and those protected from modifications with (as root) chattr +i ~/.config/xfce4/desktop/icons*
and chattr +i ~/desktop/* )

Last edited by rolgiati (2018-02-21 16:39:31)

Offline

#2 2018-02-21 13:16:40

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,832

Re: Inhibiting the panel ? (SOLVED)

Not sure if you can just uninstall the package if you don't need it - depends on how your distro handles it with dependencies. The other option is to override the executable. Create a /usr/local/bin/xfce4-panel executable file with the following content:

#!/bin/sh
exit 0

Offline

#3 2018-02-21 16:39:05

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Inhibiting the panel ? (SOLVED)

Thanks.

First one not applicable, as un-installing xfce4-panel caused a number of others to be pulled too, including Thunar and PCmanFM  ;-3(

Second one, sadly, did not work; panel still came up after boot.

But it gave me the idea for a third one that worked:

Wrote a new xfce4-panel as per your advice, but plonked it in /usr/bin after doing there a mv xfce4-panel xfce4-panel.bak

I will now protect the new xfce4-panel with chattr +i to ensure it does not get replaced in a future software update.

Thanks again.

Offline

Board footer

Powered by FluxBB