Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-02-28 16:38:13

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 83

set disk spindown on restart

All:

I'm not sure who's doing it, but my second HDD, which is only used for backup, keeps losing it's spindown setting, that is, I keep finding it 'active/idle' when it should be 'standby'.  I have:

hdparm -S60y /dev/sda; hdparm -S60y /dev/sdb

in /etc/rclocal, but it seems to be that when xfce starts up it feels the need to poll both disks and the above settings are lost.  Not sure tho.  Is there some way to run that command as the very last thing that will happen before my machine is fully restarted and anyone who might be tinkering with the disk is finished?  I usually hibernate my machine and when restarting, again, the spindown setting is lost, so this might not be xfce's issue, but xfce probably has the final kick at the can so is the best bet as to where to finally set hdparm as the very last thing that happens before I get control.

Offline

#2 2018-02-28 19:28:38

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: set disk spindown on restart

The second answer here suggests using gnome-disk-utility, have you tried it?

Offline

#3 2018-02-28 19:53:45

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 83

Re: set disk spindown on restart

Thanks, lots of interesting leads there, I'll try a few.

Offline

#4 2018-03-01 03:46:01

rayandrews
Member
From: Vancouver B.C. Canada
Registered: 2011-12-30
Posts: 83

Re: set disk spindown on restart

What worked is adding a new item to 'Session and Startup'.  Created an item running the command 'hdparm -y /dev/sdb' and now she sleeps.

Offline

Board footer

Powered by FluxBB