Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-02-28 17:49:33

Kallestofeles
Member
Registered: 2017-04-24
Posts: 4

Mapping tilde key makes ä (pressed 0x28 unpressed 0xa8) unusable

Greetings,

I ran across a strange bug - when mapping the Tilde key ^ to anything (love it for drop-down terminal), it buggs out the Ää key on estonian keyboard layout. (the second key to the right of "L" on nordic/swedish/norwegian layouts... or with showkey -s, the key named 0x28 0xa8)
When tilde is mapped (^ 0x29 0xa9), then the keypress for Ä is registered (shows up in showkey), however no output of a keypress is actually returned - meaning that you don't get the character on the screen.
I googled around a bit, but did not find a solution for this other than to unmap tilde from anything.

Has anyone else encountered this as well? Is there a fix?


Best regards,
Kalle

Offline

#2 2018-02-28 19:42:27

alcornoqui
Member
Registered: 2014-07-28
Posts: 258

Re: Mapping tilde key makes ä (pressed 0x28 unpressed 0xa8) unusable

I was very proud of myself (and of Duck Duck Go), but then I noticed that this post from the Manjaro forums from last autumm, marked as solved, was... written by you!

Sorry, and good luck!

Offline

#3 2018-03-01 06:21:30

Kallestofeles
Member
Registered: 2017-04-24
Posts: 4

Re: Mapping tilde key makes ä (pressed 0x28 unpressed 0xa8) unusable

Hahaha, thank you! I had completely forgotten about it! If I only had remembered it before I spent a day troubleshooting the hell out of ckb-next. big_smile
Went through the bugzilla and it seems I'm not the only one who has noticed this behavior:
https://bugzilla.xfce.org/show_bug.cgi?id=12531

I guess not much can be done with this thread, unless someone knows a workaround which is not un-mapping the tilde key.
Thank you alcornoqui for the quick search and a reminder! smile

Offline

Board footer

Powered by FluxBB