Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-04-08 07:13:29

ibart
Member
Registered: 2018-04-08
Posts: 5

Panel: windows list dimension & panel doesn't dodge maximized windows

Hi, I just switched from unity to xubuntu. So now I am cusomizing xfce to looks like unity. big_smile

I have two troubles:

1) windows list panel is too small, I would like to have something like with 200 or 300 px of width.
2) my new "unity luncher" doesn't dodge maximized windows. Would be nice to have this option. While browsing or clicking the X button to close a maximized the panel window pops up... I am on a 13 inch laptop, so every pixel counts.

dnplz1Vl.png

Thanks for any help.

Last edited by ibart (2018-04-08 07:14:03)

Offline

#2 2018-04-08 11:16:19

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

Hello and welcome to the forum.

For 1) you can take a look at this thread, that ends with ToZ saying:

Have a look at this page. Specifically the section of XfceTasklist and the menu-max-width-chars variable.

For 2) use the Settings > Panel > Display tab > "Automatically show and hide the panel" options, including the "Reserve space on borders" checkbox, and tweak to your liking.

Offline

#3 2018-04-08 12:36:34

ibart
Member
Registered: 2018-04-08
Posts: 5

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

Thanks for your reply. I am kinda noob.

Adding this

style "xfce-tasklist-style"
{
  # The maximum length of a button before the label ellipsizes.
  # When this value is set to -1 the button will expand to the
  # entire available space.
  XfceTasklist::max-button-length = 400

  # Ellipsizing used in the task list and overflow menu labels.
  XfceTasklist::ellipsize-mode = PANGO_ELLIPSIZE_END

  # Lucency of minimized icons. Valid values are between 0 (completely
  # hide the icon) and 100 (don't lighten the icon).
  XfceTasklist::minimized-icon-lucency = 75

  # Maximum number of characters in the menu label before it will
  # be ellipsized.
  XfceTasklist::menu-max-width-chars = 48
}
class "XfceTasklist" style "xfce-tasklist-style"

to /usr/share/themes/Adwaita/gtk-2.0/hacks.rc (using Aswaita and refeshing the theme switching from this to another one) nothing happens.

About #2, the "intellihide" doesn't do the trick. I tried the dock named PLANK and it has the feature I am looking for (dodge maximized windows) BUT i cannot positioning the dock under the top panel... so I will stick with the default panel.

What am I doing wrong editing the theme?

Thanks.

Offline

#4 2018-04-08 13:44:34

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

I'm not so sure, but I think the file you have to modify (create if it doesn't exist) is ~/.gtkrc-2.0 (that is, for example: /home/ibart/.gtkrc-2.0).

Offline

#5 2018-04-09 05:30:22

ibart
Member
Registered: 2018-04-08
Posts: 5

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

#1 Solved... I needed a reboot. The simple switching theme trick doesn't work.
#2 it is not what I am looking for. I need an option to dodge the window, like "do not reveal if a maximized window is on the way". Thanks anyway.

Offline

#6 2018-04-09 07:21:00

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 973

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

ibart wrote:

#2 it is not what I am looking for. I need an option to dodge the window, like "do not reveal if a maximized window is on the way". Thanks anyway.

I am not sure what you mean. Do you mean for the panel to not cover the maximized window (in other words, to "not reveal" itself) when you maximize that window? Because that's what NOT checking the "Don't reserve space on borders" option when you set the auto-hide option to never (and, I would guess - but am not sure - the "Intelligently" option) does.

If that's not it... I do not know how the panel can change its behavior between the moment that a window is in an unmaximized state and the moment it is in a maximized one - which would seem to be what the words "a maximized window is on the way" mean.

Again, I am not sure that I am understanding what you mean. Although I am more ignorant than most, here, it is possible that others may also be unsure of what you mean - and, if that is the case, it could be causing some delay in one of them figuring out what the correct answer to your question is. So... can you clarify, please?

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#7 2018-04-09 12:01:46

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

MDM, yeah: Ibart, could you clarify about that?

And on #1, the changes were on /usr/share/themes/Adwaita/gtk-2.0/hacks.rc or ~/.gtkrc-2.0?

Because I think there's a difference, the 1st would apply to the Adwaita theme, for all users, the 2nd for your user, across themes, wouldn't it?

Offline

#8 2018-04-09 14:41:47

ibart
Member
Registered: 2018-04-08
Posts: 5

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

alcornoqui wrote:

MDM, yeah: Ibart, could you clarify about that?

And on #1, the changes were on /usr/share/themes/Adwaita/gtk-2.0/hacks.rc or ~/.gtkrc-2.0?

Because I think there's a difference, the 1st would apply to the Adwaita theme, for all users, the 2nd for your user, across themes, wouldn't it?

You are right. I edited just that theme, but I will modify the file globally.

MountainDewManiac wrote:
ibart wrote:

#2 it is not what I am looking for. I need an option to dodge the window, like "do not reveal if a maximized window is on the way". Thanks anyway.

I am not sure what you mean. Do you mean for the panel to not cover the maximized window (in other words, to "not reveal" itself) when you maximize that window? Because that's what NOT checking the "Don't reserve space on borders" option when you set the auto-hide option to never (and, I would guess - but am not sure - the "Intelligently" option) does.

If that's not it... I do not know how the panel can change its behavior between the moment that a window is in an unmaximized state and the moment it is in a maximized one - which would seem to be what the words "a maximized window is on the way" mean.

Again, I am not sure that I am understanding what you mean. Although I am more ignorant than most, here, it is possible that others may also be unsure of what you mean - and, if that is the case, it could be causing some delay in one of them figuring out what the correct answer to your question is. So... can you clarify, please?

Regards,
MDM

Do you see my point? https://www.youtube.com/watch?v=lfSURNO … e=youtu.be

If I maximize a window the deskbar disappears (with intellihide). I would like to have the deskbar always hidden BELOW/BEHIND any window... so even if I move the mouse over the deskbar (which is hidden by maximized window) I would like to have it hidden. In my opinion, the trigger that activate the deskbar has to have a switch to turn itself off.

Offline

#9 2018-04-09 18:08:13

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

You can set a bigger delay (default 225ms), or make the border even tinier (default 3 pixels):

XfcePanelWindow
---------------
style "xfce-panel-window-style"
{
  # Time in miliseconds before the panel will unhide on an enter event
  XfcePanelWindow::popup-delay = 225

  # Time in miliseconds before the panel will hide on a leave event
  XfcePanelWindow::popdown-delay = 350

  # Size of autohide window in pixels
  XfcePanelWindow::autohide-size = 3
}
class "XfcePanelWindow" style "xfce-panel-window-style"

(or that says the same .gtkrc-2.0 link)

I'm not sure if you can get exactly what you want without tweaking those properties.

Offline

#10 2018-04-10 06:08:30

ibart
Member
Registered: 2018-04-08
Posts: 5

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

alcornoqui wrote:

You can set a bigger delay (default 225ms), or make the border even tinier (default 3 pixels):

XfcePanelWindow
---------------
style "xfce-panel-window-style"
{
  # Time in miliseconds before the panel will unhide on an enter event
  XfcePanelWindow::popup-delay = 225

  # Time in miliseconds before the panel will hide on a leave event
  XfcePanelWindow::popdown-delay = 350

  # Size of autohide window in pixels
  XfcePanelWindow::autohide-size = 3
}
class "XfcePanelWindow" style "xfce-panel-window-style"

(or that says the same .gtkrc-2.0 link)

I'm not sure if you can get exactly what you want without tweaking those properties.

Great trick. Changing the XfcePanelWindow::popup-delay to 3 seconds does what I need. smile There is still a thing that annoying me, even if I am more than satisfied with xfce. I don't like how icons in my new unity-like luncher reacts to a click. After a click the luncher creates a new instance but (for example the browser) if the application is already started it would be nice to have the deskbar maximing the already running process. Anyone, thank you very much for your help. Bye!

Offline

#11 2018-04-10 09:49:33

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Panel: windows list dimension & panel doesn't dodge maximized windows

ibart wrote:

There is still a thing that annoying me, even if I am more than satisfied with xfce. I don't like how icons in my new unity-like luncher reacts to a click. After a click the luncher creates a new instance but (for example the browser) if the application is already started it would be nice to have the deskbar maximing the already running process.

Take a look at Dockbarx (and their components, specially xfce4-dockbarx-plugin): https://github.com/M7S/dockbarx

I have it available (but not installed) through the WebUp8 PPA. I think it does what you want.

Offline

Board footer

Powered by FluxBB