Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-06-06 09:08:42

BFG
Member
Registered: 2018-06-06
Posts: 7

Volume notification is haunted

I've put up with this for ages and many rebuilds, but I had hoped that it would finally stop now that I've installed Ubuntu 18.04 with XFCE on top.

A volume notification will show itself at random, despite no changes to volume being made and no media apps being run. Sometimes it's very intrusive and will show every few seconds.  I looked into this a few years back and couldn't find a decent solution which didn't come with side-effects on sound function, so I just put up with it.

I'm posting now because my partner's dual-boot machine is getting more XFCE use and she finds it impossible to ignore this fault and has asked me to exorcise the demons.

Any suggestions most welcome

Offline

#2 2018-06-06 09:40:47

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Volume notification is haunted

Hello and welcome to the forum.

I don't have this problem myself, but I've found a couple of posts that might be of interest:

Sound popup showing every minute in xubuntu

Ubuntu is showing multiple notification when volume is changed

Please tell us how it goes, good luck!

Offline

#3 2018-06-06 09:53:17

BFG
Member
Registered: 2018-06-06
Posts: 7

Re: Volume notification is haunted

Hi!  Thanks for the quick reply.  Those are some of the solutions which helped in the past, but something has changed.  Perhaps i need to find the up-to-date equivalent of xfce4-volumed because it no longer seems to exist in 16.04 onward. 

killall xfce4-volumed
xfce4-volumed: no process found

EDIT:  The part about xfce4-volumed is incorrect, I had already disabled it in previous investigations.

Last edited by BFG (2018-06-06 10:53:18)

Offline

#4 2018-06-06 09:58:34

alcornoqui
Member
Registered: 2014-07-28
Posts: 295

Re: Volume notification is haunted

Well, no worries, I think some of our forum peers will show with some good info in the next hours/days, you'll see!

Offline

#5 2018-06-06 11:01:06

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,626

Re: Volume notification is haunted

The updated version of xfce4-volumed is xfce4-volumed-pulse. The xfce4-pulseaudio-plugin also displays sound notifications and can be turned off.

However, it sounds like there is something going on with pulseaudio if you are getting sound notification changes without changing sounds. Follow these instructions to get a pulseaudio log to see what is happening there.

Another thing to try is to create a second test account on your computer and log in with that account. Make no configuration changes (leave everything at its defaults) and see if it happens then as well. This would help to determine if its a systemic problem or something related just to you login.

Offline

#6 2018-06-06 11:18:15

BFG
Member
Registered: 2018-06-06
Posts: 7

Re: Volume notification is haunted

It's strongly related to “Indicator Plugin”, as if this is removed from the panel, the random notifications stop.  But of course so do all other notifications.

Things tried:

1. disabling xfce4-volumed

  killall xfce4-volumed

- To disable xfce4-volumed permanently open Session and Startup from settings manager. Go to Application Autostart tab. Look for XFCE Volume Daemon (pulseaudio) and untick it to disable.

No effect. Problem still showing.


2. Modify “Indicator Plugin” to remove sound:

- Right click on an empty space of the Panel -> Panel -> Panel Properties
- Go to Items Tab
- Select Indicator Plugin
- Click on the right side small cog icon.
- Place a tick mark for the Sound Menu entry. This will be hidden on next panel restart.
- Close this Indicators window.
- Press Alt-F2 to bring Run command dialog box.
- Type xfce4-panel -r and Hit

No effect. The tick is still shown in the "hidden" column, but the volume notification still annoys. Reboot just in case, still there.

3. Added xfce4-pulseaudio-plugin

  sudo apt install xfce4-pulseaudio-plugin
- right click on the panel -> Panel -> Add New Items and Add PulseAudio Plugin

Same fault, but now results in two notifications being shown simultaneously.

Changed xfce4-pulseaudio-plugin settings with:
- Right click on an empty space of the Panel -> Panel -> Panel Properties
- Go to Items Tab
- Select PulseAudio Plugin
- Click on the right side small cog icon.
- Disable keyboard shortcuts and show notifications when volume changes.

Result: Now back to only one notification being shown.

Re user profile:
I just renamed the user's home folder and created a new blank folder to get a fresh session.  The problem was immediately present.

This is on a Ubuntu 16.04 install with XFCE added and gnome/unity removed. Which might be a factor - but this is also happening on 18.04 installed the same way.


I'll do the logs next.  Thanks guys.

Last edited by BFG (2018-06-06 11:19:12)

Offline

#7 2018-06-06 11:44:40

BFG
Member
Registered: 2018-06-06
Posts: 7

Re: Volume notification is haunted

I've captured the log and uploaded here.

https://files.fm/u/mudfnxz3

pulseverbose.log 477.89 KB

Thanks smile

Offline

#8 2018-06-06 13:27:32

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,626

Re: Volume notification is haunted

BFG wrote:

It's strongly related to “Indicator Plugin”, as if this is removed from the panel, the random notifications stop.  But of course so do all other notifications.

This is interesting. If you have the package "indicator-sound" installed, remove it. Use xfce4-pulseaudio-plugin instead (enable notifications in the plugin). I wonder whether the indicator-sound package is causing the issue - it would reside in the indicator plugin.

I'll review the pulseaudio logs to see if anything sticks out.

Edit: the pulseaudio log file shows the headphones being plugged and unplugged. Was this the case? If not, this is probably the cause of the continuous notifications.

(  15.936|  10.044) D: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in
(  15.936|   0.000) D: [pulseaudio] device-port.c: Setting port analog-output-headphones to status yes
(  15.936|   0.000) D: [pulseaudio] module-switch-on-port-available.c: Trying to switch to port analog-output-headphones
(  15.936|   0.000) D: [alsa-sink-ALC887-VD Analog] alsa-mixer.c: Activating path analog-output-headphones
.....
(  15.957|   0.019) D: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now unplugged
(  15.957|   0.000) D: [pulseaudio] device-port.c: Setting port analog-output-lineout to status yes
(  15.957|   0.000) D: [pulseaudio] module-switch-on-port-available.c: Trying to switch to port analog-output-lineout
(  15.957|   0.000) D: [alsa-sink-ALC887-VD Analog] alsa-mixer.c: Activating path analog-output-lineout

Last edited by ToZ (2018-06-06 13:36:17)

Offline

#9 2018-06-06 13:43:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,626

Re: Volume notification is haunted

Here is a bug report with a solution to use hdajackretask to fix the issue.

Offline

Board footer

Powered by FluxBB