Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-06 13:35:42

imthenachoman
Member
Registered: 2016-08-27
Posts: 21
Website

shortcut keys on release instead of press

Apparently this is a very old issue/bug (i.e. https://bugzilla.xfce.org/show_bug.cgi?id=7845).

Seeing at its been 8 years since the bug was reported I wanted to create a new post to see if there are newer/better solutions.

I can't help by wonder this isn't the default behavior in XFCE now...

Offline

#2 2018-07-23 23:37:15

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,755

Re: shortcut keys on release instead of press

You can use ksuperkey to get that functionality until the issue is resolved.

Offline

#3 2018-07-24 02:02:32

imthenachoman
Member
Registered: 2016-08-27
Posts: 21
Website

Re: shortcut keys on release instead of press

ToZ wrote:

You can use ksuperkey to get that functionality until the issue is resolved.

I couldn't find how to install ksuperkey on xfce but I did find https://github.com/JixunMoe/xfce-superkey which works brilliantly.

Thank you!

Offline

#4 2018-07-25 13:47:23

Misko_2083
Member
Registered: 2015-10-13
Posts: 77
Website

Re: shortcut keys on release instead of press

In Debian repo there is "xcape".
Runs as daemon.
Let's say you want to run application finder with Super key.
Run:

xcape -e 'Super_L=Alt_L|F2'

This will run application finder but only on release so it doesn't interfere with any other super key combinations.

Offline

#5 2018-07-25 14:13:22

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,755

Re: shortcut keys on release instead of press

Nice alternative, thanks.

Offline

#6 2018-07-25 20:38:13

alcornoqui
Member
Registered: 2014-07-28
Posts: 309

Re: shortcut keys on release instead of press

I use xcape too, for the same reason of being in the default repos, but beware, users: It consumes all of 300 kilobytes of RAM and 0% CPU!

;-)

Full instructions for Debian/Ubuntu/Mint, etc:

sudo apt install xcape

Go to Settings > Sesion and Startup > Application Autostart tab > Add button

Name: Xcape
Comment: Converts Alt+F1 in Super key
Command: xcape -e 'Super_L=Alt_L|F1'

Substitute Alt+F1 for the shortcut you use for Whisker Menu.

I don't really mind that much if it isn't the default when it's so easy to achieve...

Offline

#7 2018-07-25 23:06:29

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 495
Website

Re: shortcut keys on release instead of press

alcornoqui wrote:

I use xcape too, for the same reason of being in the default repos, but beware, users: It consumes all of 300 kilobytes of RAM and 0% CPU!

;-)

Full instructions for Debian/Ubuntu/Mint, etc:

sudo apt install xcape

Go to Settings > Sesion and Startup > Application Autostart tab > Add button

Name: Xcape
Comment: Converts Alt+F1 in Super key
Command: xcape -e 'Super_L=Alt_L|F1'

Substitute Alt+F1 for the shortcut you use for Whisker Menu.

I don't really mind that much if it isn't the default when it's so easy to achieve...

Thanks for that. It works in Fedora where Ksuperkey isn't in the repos but xcape is. Just replace apt with dnf in your guide smile.

Offline

#8 2018-07-26 10:38:38

Spass
Member
From: Poland
Registered: 2016-12-07
Posts: 85
Website

Re: shortcut keys on release instead of press

Misko_2083 & alcornoqui, I'm another happy camper here want to thank you. Such a small but useful thing. I've installed it on both of my machines with Xubuntu.

Autostart command for Xubuntu users: xcape -e 'Super_L=Control_L|Escape'


xubuntu-pl (Polish Xubuntu Community)

Offline

#9 2018-07-26 11:35:29

imthenachoman
Member
Registered: 2016-08-27
Posts: 21
Website

Re: shortcut keys on release instead of press

Hopefully they fix this in the next update of XFCE. I can't think of a reason anyone would want shortcuts to ever work on key down instead of key up.

Offline

Board footer

Powered by FluxBB