Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-18 02:37:51

thalesmaia
Member
Registered: 2018-07-18
Posts: 2

Desktop Zoom

Hi, I've searched for 2 days now without an plausible answer.

I have zoom_desktop enable, but I can't zoom! I need to work with Alt + Scroll due to some vision problems.
I'm using GalliumOS and I have my doubts if this resource is enable.

I need some guidance to check in CLI and change the keyboard shortcut to test it.

Offline

#2 2018-07-18 06:49:19

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 497
Website

Re: Desktop Zoom

It uses the "grab" key which is set in settings - window manager tweaks - accessibility. If that is set to something other than Alt then you need to use the key. I believe some distros set that to Ctrl.

Offline

#3 2018-07-18 07:19:41

Spass
Member
From: Poland
Registered: 2016-12-07
Posts: 85
Website

Re: Desktop Zoom

thalesmaia, the standard Xfce zoom feature seems to work only when the Xfwm compositing is enabled and GalliumOS uses Compton by default, so that's why it probably doesn't work on your machine. Unfortunately I don't know a way to make it work on Compton, I'm not familiar with it.

This recent thread seems related: https://forum.xfce.org/viewtopic.php?pid=48976#p48976


xubuntu-pl (Polish Xubuntu Community)

Offline

#4 2018-07-18 12:44:49

alcornoqui
Member
Registered: 2014-07-28
Posts: 312

Re: Desktop Zoom

This thread in Compton's GitHub is informative: https://github.com/chjj/compton/issues/188

There are some alternatives mentioned, but no feature implementation.

GalliumOS is for Chromebooks, right? I searched for "zoom" in their subreddit and GitHub and I didn't find anything very good; the suggestions were:

- Increase DPI: https://www.reddit.com/r/GalliumOS/comm … 5_scaling/

- Using a HiDPI theme: https://www.reddit.com/r/GalliumOS/comm … ar_screen/ & https://www.reddit.com/r/GalliumOS/comm … nging_the/

sad

Offline

#5 2018-07-18 15:31:28

thalesmaia
Member
Registered: 2018-07-18
Posts: 2

Re: Desktop Zoom

I'm not really sure if I'm happy (finally understood the problem) or sad (have no idea how to solve it without changing distros).

Really appreciate all the help! I'm will ask developers for good alternatives.

Offline

#6 2018-07-18 18:47:53

alcornoqui
Member
Registered: 2014-07-28
Posts: 312

Re: Desktop Zoom

Be happy, we're closer smile

Can you use xzoom?

Offline

#7 2018-07-30 23:25:29

rogue_ronin
Member
Registered: 2015-03-03
Posts: 13

Re: Desktop Zoom

Perhaps you could disable compton (is it in Sessions and Startup?)  Then you could just enable XFCE's compositing in Window Manager Tweaks.

Bit of a workaround, compton has better compositing, but might solve your issue natively.

Aloha.

Offline

#8 2018-08-21 01:00:28

mint4all
Member
From: America
Registered: 2018-08-21
Posts: 63

Re: Desktop Zoom

Greetings!

Afaik, Xfce 4.12+ provides a built-in feature to control its window manager's compositing: Whisker-menu button > All Settings button > Personal section > Desktop Settings button > Window Manager dropdown > {select your choice of compositing options }. The window manager (xfwm4) should reset immediately; if not, simply logout+login or reboot instead.

Cheers, M4A


Linux Mint 18.3-xfce & Linux Mint 19-xfce  -- Dell Precision T1500 Desktops -- Toshiba Satellite Laptop -- Family & Community Support re. Linux

Offline

Board footer

Powered by FluxBB