Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-11-19 06:15:02

cjsmall
Member
Registered: 2012-12-02
Posts: 23

Xubuntu 18.10 broke my dual monitor dual desktop

For many years and on many versions of Xubuntu I have had a dual monitor set up, running a separate desktop on each monitor.  After upgrading to 18.10 today, I'm up and running on my primary monitor (display :0.0), but nothing is displaying on the second monitor (display :0.1).  However, the second monitor is not dark.  When the desktop displays on :0.0, the :0.1 screen goes to a uniform light grey.  It is being recognized, but the desktop session isn't being launched.

I have an Nvidia K4000 GPU and the system was using the v390 drivers, which I subsequently upgraded to the new 415 version.  Updating the drivers made no change in behavior.  To make sure that this wasn't a hardware problem, I activated Xinerama mode, rebooted, and the desktop did indeed span across the two screens, but this is not what I'm looking for.  I need my two independent desktops on either monitor.

So, can anyone suggest where to look for the problem?  I'm wondering if this might be a dbus issue, but I'm not familiar enough with that to look more deeply there.

Here is the monitor configuration from the /etc/X11/xorg.conf file.  Nothing substantial has changed.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 415.13


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 1600 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Planar Systems, Inc."
    ModelName      "PX212M"
    HorizSync       31.0 - 92.0
    VertRefresh     56.0 - 86.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Planar Systems, Inc."
    ModelName      "PX212M"
    HorizSync       31.0 - 92.0
    VertRefresh     56.0 - 86.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K4000"
    BusID          "PCI:4:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K4000"
    BusID          "PCI:4:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "DVI-I-0: 1600x1200 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DP-2: 1600x1200 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "(null)" "Disable"
EndSection

Thanks.

Offline

#2 2018-11-27 11:09:30

cjsmall
Member
Registered: 2012-12-02
Posts: 23

Re: Xubuntu 18.10 broke my dual monitor dual desktop

I'd like to augment this post with some new important information:

When I boot the system, the second monitor receives signal and goes active with the screen turning a uniform grey.  An xfce4 desktop session starts on monitor #1 (display :0.0) but not on the second monitor (:0.1) located to the left.  Nevertheless, the mouse navigates to the second monitor and appears as a pointer on the screen.  Also, the screen saver (Xscreensaver) starts up on the second monitor at the same time as on the first.

From the Settings menu:
    * Nvidia  shows a single display  (image)
    * ARrandR shows a single display  (image)
    * Display shows a single display  (image)

However, the system is properly configured for two monitors as can be seen by the Nvidia X Server Configuration  (image) and by inspecting /etc/X11/xorg.conf (shown above).

Things I've attempted or checked:

    * Xubuntu 18.04 was using the proprietary v390 driver package and this was retained after the upgrade to 18.10.  A change was made to use the open source v415 drivers, but this had no effect.  (image)

    * The second monitor was initially attached to the K4000 GPU DP-2 port.  To rule out any possible hardware problem, the monitor was moved to DP-3 with no change.

    * A review of /var/log/Xorg.0.log shows no errors.

Questions:

    * Why is the second monitor active but not being detected on DP-3 by the OS?  What needs to be addressed to rectify this?

    * Why didn't the dual-desktop configuration get preserved between 18.04 and 18.10?  What needs to be done to reactivate a desktop on the second monitor?

Here is some additional info:

-------------------------------------------------------------------------------
# xrandr
Screen 0: minimum 8 x 8, current 1600 x 1200, maximum 16384 x 16384
DVI-I-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 432mm x 324mm
   1600x1200     60.00*+
   1280x1024     85.02    75.02    60.02
   1024x768      85.00    75.03    70.07    60.00
   800x600       85.06    75.00    72.19    60.32    56.25
   640x480       85.01    75.00    72.81    59.94
DVI-I-1 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
-------------------------------------------------------------------------------

-------------------------------------------------------------------------------
# lshw -c video
  *-display
       description: VGA compatible controller
       product: GK106GL [Quadro K4000]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:84 memory:b2000000-b2ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:a000(size=128) memory:c0000-dffff
-------------------------------------------------------------------------------

Offline

#3 2019-01-04 19:16:11

kc12
Member
Registered: 2019-01-04
Posts: 1

Re: Xubuntu 18.10 broke my dual monitor dual desktop

Did you ever find a solution/resolution for this?

I'm facing a similar issue, although in Fedora.

Offline

#4 2019-03-10 09:24:24

gert
Member
Registered: 2019-03-10
Posts: 1

Re: Xubuntu 18.10 broke my dual monitor dual desktop

I also came across this problem now using an Intel graphics card. With xfwm I can't get windows on the 0.1 screen, but I can one open there by specifying the display on the command line. Then when I move the mouse to the second screen it gets caught there and I can't move it back to the first screen. Something similar happens with mate. Both xfce and mate I've used on this type of Zaphodhead setup before, but that was when they were still using gtk2 as back end.

Currently I got something running by using blackbox as window manager. I still can get panels only on one screen and on 0.1 the settings don't seem to work on the second screen, probably because the daemon is  run with --display :0.0 and running one with display :0.1 doesn't seem to be possible. I still have an old Gentoo installation where all this works. Currently, I don't have access to it, but AFAIK there I have still mostly xfce4 4.11 programs linked against gtk2.

Offline

#5 2019-03-28 19:19:02

cjsmall
Member
Registered: 2012-12-02
Posts: 23

Re: Xubuntu 18.10 broke my dual monitor dual desktop

Sorry I missed the reply going back to January!

No, I have not received and help in resolving the issue.  I have filed two bug reports.  The first was to the Xfce4 group and it can be found here:

https://bugzilla.xfce.org/show_bug.cgi?id=15116

The only response was to finally punt it over to the Ubuntu development, so I just posted a report here:

https://bugs.launchpad.net/ubuntu/+bug/1822181

I suggest that you monitor these two reports, and I would appreciate it if you could add details regarding your problems to the latter bug report, as it will help spur investigation if it is seen to be something affecting multiple people.  Clearly there is some change that was made that has broken things, and the more data points we can accumulate, the better the chance of resolving this.

Regards,
--
Jeff

Offline

Board footer

Powered by FluxBB