Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-11-26 17:29:36

jclc
Member
Registered: 2018-11-26
Posts: 3

Xfwm compositor locked to 60Hz

Hi, I recently installed Manjaro Xfce on my desktop and found out that my 144Hz monitor only runs at 60Hz. I have 2 monitors, the other one is 60Hz. Disabling the compositor makes them both run at the proper frequencies. Compton also refreshes both monitors at the right frequencies, but it has other problems that make it unusable. I'm using the latest Nvidia proprietary drivers and I've set the settings correctly in nvidia-settings and Xfce's monitor settings. Prior to installing Manjaro I used Arch and the compositor ran flawflessly. Any tips?

Edit: I should add that I the same issue earlier this year, but it fixed itself somehow. This is why I hate it when something fixes itself magically.

Last edited by jclc (2018-11-26 20:02:13)

Offline

#2 2018-11-27 01:05:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,860

Re: Xfwm compositor locked to 60Hz

Hello and welcome.

This is most probably a driver issue. See this bug report.

Here is a walkthrough using xrandr to create a custom resolution/refresh rate. Here is something similar from the Arch wiki. Perhaps these will help?

Offline

#3 2018-11-27 18:37:56

jclc
Member
Registered: 2018-11-26
Posts: 3

Re: Xfwm compositor locked to 60Hz

Notice who posted that original bug report wink

Anyway, I really do not think it's the driver's fault. I've properly configured the framerate and it works fine with other compositors. However I did see this in xrandr's output:

DP-0 connected primary 1920x1080+0+0 (0x1db) normal (normal left inverted right x axis y axis) 598mm x 336mm
	Identifier: 0x1da
	Timestamp:  100864
	Subpixel:   unknown
	Gamma:      0.80:1.0:1.2
	Brightness: 0.87
	Clones:    
	CRTC:       0
	CRTCs:      1 0 2 3
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	CscMatrix: 65536 0 0 0 0 65536 0 0 0 0 65536 0 
	EDID: 
		00ffffffffffff0005e390279c070000
		331b0104a53c22783b5835a655539f28
		0e5054bfef00d1c081803168317c4568
		457c6168617c023a801871382d40582c
		450056502100001efc7e808870381240
		1820350056502100001e000000fc0032
		3739305747350a2020202020000000fd
		001e92a0a021010a2020202020200142
		02031ef14b0103051404131f12021190
		230907078301000065030c001000866f
		80a0703840403020350056502100001e
		fe5b80a0703835403020350056502100
		001e011d007251d01e206e2855005650
		2100001eab22a0a050841a3030203600
		56502100001a7c2e90a0601a1e403020
		360056502100001a0000000000000046
	BorderDimensions: 4 
		supported: 4
	Border: 0 0 0 0 
		range: (0, 65535)
	SignalFormat: DisplayPort 
		supported: DisplayPort
	ConnectorType: DisplayPort 
	ConnectorNumber: 3 
	_ConnectorLocation: 3 
	non-desktop: 0 
		supported: 0, 1
  1920x1080 (0x1c1) 148.500MHz +HSync +VSync +preferred
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz
  1920x1080 (0x1db) 325.080MHz +HSync +VSync *current
        h: width  1920 start 1944 end 1976 total 2056 skew    0 clock 158.11KHz
        v: height 1080 start 1083 end 1088 total 1098           clock 144.00Hz
  1920x1080 (0x1dc) 285.500MHz +HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock 137.26KHz
        v: height 1080 start 1083 end 1088 total 1144           clock 119.98Hz
  1920x1080 (0x1dd) 235.500MHz +HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock 113.22KHz
        v: height 1080 start 1083 end 1088 total 1133           clock  99.93Hz
  1920x1080 (0x1c2) 148.350MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.43KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  59.94Hz

etc etc...

Could it be that Xfwm is using the "preferred" refresh rate instead of the current one? Also, how can I change or disable vsync in the compositor? Nvidia's drivers are already taking care of tearing.

Offline

#4 2018-11-28 00:48:51

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,860

Re: Xfwm compositor locked to 60Hz

jclc wrote:

Also, how can I change or disable vsync in the compositor? Nvidia's drivers are already taking care of tearing.

Have a look at:

xfwm4 --help

If your version supports the "--vblank" parameter, you can run:

xfwm4 --vblank=off --replace

Offline

#5 2018-11-28 01:37:40

jclc
Member
Registered: 2018-11-26
Posts: 3

Re: Xfwm compositor locked to 60Hz

Thanks for the response. It didn't seem to make a difference... "off" and "glx" run about the same while "xpresent" makes moving windows incredibly sluggish

Offline

Board footer

Powered by FluxBB