Xfce Forum

Sub domains

You are not logged in.

#1 2019-04-24 10:54:29

Registered: 2019-04-24
Posts: 2

[SOLVED] Cannot delete Thunar directory shortcut

Hi everyone,

I have a strange problem with Thunar, and I've looked hard trying to find a solution but I can't find anything that's similar to my issue. Or maybe I'm not searching with the right keywords tongue

Anyway, I've added a shortcut to a directory to Thunar's side pane, under the Places bit. I cannot remove it permanently, no matter what I do. I can right click on the directory then click "Remove Item". It'll be removed until I open Thunar within another application (or however it works, like if I choose where to save a download in Firefox, or if I open a document in LibreOffice, and that file explorer window appears), then the shortcut will appear again.

I've deleted the directory that I made the shortcut from. It will still appear in the application file explorer. Clicking on it just takes me to the directory before it. I've deleted all the contents in ~/.config/gtk-3.0/bookmarks. It'll just add the directory in that file again (but not create the actual directory). I've deleted my Xfce and Thunar config files and the problem still persists. I honestly don't know how to reproduce these steps because I had done pretty much the same thing with another directory and I could remove that one fine.

Anyone have any ideas on how to fix this?

I'm using Manjaro Xfce.

Last edited by Vellfire (2019-04-25 03:28:52)


#2 2019-04-24 23:32:28

From: Canada
Registered: 2011-06-02
Posts: 5,696

Re: [SOLVED] Cannot delete Thunar directory shortcut

Hello and welcome.

The other applications use GTK's FileChooserDialog for save and open functions. This is not thunar. If I'm understanding correctly, the item has been removed from thunar but still appears in the other application's (filechooser dialog) during open and save functions.

Assuming these other applications are based on GTK3, they should be using ~/.config/gtk-3.0/bookmarks. Can you check if you have a ~/.local/share/gtk-3.0/bookmarks file as well? It might be listed in there. If it does exist, try deleting (or renaming if it you want to keep it around) it.


#3 2019-04-25 03:25:52

Registered: 2019-04-24
Posts: 2

Re: [SOLVED] Cannot delete Thunar directory shortcut

Yes, that's about right.

I did a file search and there wasn't anything under ~/.local/share, but it did find another bookmarks file called .gtk-bookmarks in my user directory... no idea how I missed that, but I've deleted .gtk-bookmarks and now the problem is gone.

Thanks for the help smile


Board footer

Powered by FluxBB