Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-05-15 16:04:48

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 172

can't suspend

I have tried numerous searches and fixes but nothing works. I have an HP Omni200 all-in-one computer (I know it's *** but I got it as a gift). I can't suspend. It is annoying because every fix when it doesn't work require a restart. After clicking suspend the hard drive spins up and screen goes white or blue but I can't get to a graphical desktop. Keyboard shortcuts, various power manager fixes don't work. I am running xubuntu 18.04.

Offline

#2 2019-05-15 20:04:22

Misko_2083
Member
Registered: 2015-10-13
Posts: 104
Website

Re: can't suspend

A quick search on the internet on Omni200 says that adding "pci=nomsi" to the kernel boot options fixes suspend.
https://askubuntu.com/questions/1104219 … nomsi-mean

Offline

#3 2019-05-15 22:31:39

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 172

Re: can't suspend

OK I searched again and that didn't come up. But i tried the grub edit. Here is my original grub file part
CODE
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="pci=nomsi"
CODE

and here is the edited file

CODE

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
GRUB_CMDLINE_LINUX="nouveau.modeset=0"

CODE
The I did sudo update grub and restarted.The same behavior either way computer  suspends and then when I try to wake it just a blue screen. Only after the grub edit it added about 2 minutes to the boot time. I am not at all sure I edited the grub file correctly. Thank you

Last edited by cmcanulty (2019-05-17 13:17:29)

Offline

Board footer

Powered by FluxBB