Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-07-06 10:39:39

MouseFan
Member
Registered: 2019-07-02
Posts: 8

Disable fade animation

When i switch between programs it is very annoying. I was looking for a solution in Google but could not find anything. I would like to turn off any animation, including fading.

Video for example vimple.co/66fddf69118347a4850fe800bce89f70

Offline

#2 2019-07-06 12:22:27

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,087

Re: Disable fade animation

Fade animation? I wasn't aware that Xfwm offered that.

Are you using a third-party compositor?

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#3 2019-07-06 12:53:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,877

Re: Disable fade animation

It's not fading per se, it's both the default GTK3 focus dimming that happens with the toolkit (see https://developer.gnome.org/gtk3/stable … rview.html for a discussion about GTK3 widget states) and xfwm4 theme configurations.

There are two types of "fading" that are happening there.

  1. GTK3 toolkit "fading" - this is the fading that happens within the window (minus the window titlebar). You can affect these by overriding the default "backdrop" state of widgets via something like:

    *:backdrop {
            -gtk-icon-effect: none;
            color: #000000;
    }

    ...change "#000000" to the foreground colour of the elements to match your current focused foreground colour. Note that I also prevent any icons from dimming by setting the "-gtk-icon-effect" parameter.
    .

  2. The second is the titlebar dimming. This is done by xfwm4 and the theme that is selected. Have a read through the xfwm4 theme howto to get a better understanding of how xfwm4 themes work. Basically, there are different active and inactive elements in the theme that create the "fade" effect. You'll need to change those (or just copy all active elements to their corresponding inactive elements).

Offline

#4 2019-07-06 20:15:22

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,087

Re: Disable fade animation

Seems like every time I visit this forum, I read more threads from Xfce users wanting to know how to disable - or fix - another facet of this GTK garbage. Why is it that the Xfce developers are wasting spending so much time trying to switch everything over to it, again? They're tired of working on the Xfce project and figure that, once they've convinced the last of us to go with a different DE, they can stop, since at that point no one will be likely to notice?

Regards,
MDM

Last edited by MountainDewManiac (2019-07-06 20:15:54)


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#5 2019-07-06 23:37:20

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,877

Re: Disable fade animation

I can't seem to recall if this widget behaviour was the same in GTK2. Maybe its something that's been around for a while. Anyways, GTK3 Xfce is just around the corner.

Offline

#6 2019-10-07 12:24:12

oldhwman
Member
Registered: 2019-10-07
Posts: 2

Re: Disable fade animation

Hi everyone,

Apologies for reviving this old topic -- I was wondering if the great hive mind of the Internet had any new input on this. I'm happy to bring some of my own.

I haven't tried bisecting this, but I suspect this behaviour was recently(-ish) introduced by adding support for the _NET_WM_STATE_FOCUSED property. Gnome needs that because, now that they're using header bars, there's no way to show which application has focus except by dimming that application's window. Until recently, XFWM didn't export that property, so themes using the :backdrop selector didn't work properly.

GTK2 themes (thankfully) don't support that, and a bunch of other window managers don't support it, either, which is why it's been hidden so far.

Now, my questions are:

1. Is anyone aware of a way to turn that damn thing off without editing the theme? Perhaps some obscure X11 hack that I definitely no longer remember from back when messing with XF86Config was a thing, which would just drop (or force the values of) some properties from a set of windows?

2. If not, is there any interest in introducing such an option? I'd be happy to provide a patch but I'm not sure what the right way to implement this would be -- there's a very good reason why dimming is supported (i.e. headerbar apps!), and a patch that just breaks headerbar applications is just as bad as a patch that breaks non-headerbar applications. Besides, I'm not an XFCE user anymore (due to this whole GTK3 thing, I'm not a GTK user anymore so I switched to other things after the 4.12 release) and I don't really trust myself to come up with an idiomatic solution.

The back story to my question is that there's some old code of mine still running back at my alma mater. Now that their old LTS distro got upgraded, and I did the nice thing and port my old code to GTK3, the few people there not using KDE (and the old GTK2 code of my app) are going nuts. As soon as they switch to their LaTeX or LibreOffice document window, the application window containing simulation results goes dim (and pretty hard to read) -- and it's pretty annoying regardless of what applications are involved, since the whole screen starts blinking like a Christmas tree in reverse as soon as you start switching between windows. It's not too obvious on a tiny laptop screen, but these folks are using 27" monitors with 5-6 windows open at once.

I can't just tell my users to edit their theme -- their theme is Adwaita and these are 60 year-old engineers of the non-computer kind who don't know CSS and don't know or care what a theme is. I also don't want to port the GUI to Qt and tell them to use something else, either, I'd much rather fix the thing that they're using today. I could tell them to keep using the GTK2 version of my application but the other ones would still exhibit this behaviour, and I wish I could be more helpful than that...

Last edited by oldhwman (2019-10-07 12:49:50)

Offline

#7 2019-10-07 18:39:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,877

Re: Disable fade animation

@oldhwman, hello and welcome.

Not sure how much to add, but in case you haven't seen these yet:
- https://bugzilla.xfce.org/show_bug.cgi?id=11067 - the commit that added support for  _NET_WM_STATE_FOCUSED
- https://gitlab.gnome.org/GNOME/gtk/issues/777 - gnome bug report discussion about the backdrop issue.

When I look at the Adwaita theme on my system, GTK3.24.12, the backdrop differences are minimal (in the sense that I can still quite easily see the content of the non-focused windows). Are you using the built-in Adwaita theme or a packaged version of the Adwaita theme (if the later, it may no longer be relevant for the version of GTK3 you are currently running)?

As for suggestions, feel free to create a bug report to see what the developer will say.

Offline

#8 2019-10-07 20:40:22

oldhwman
Member
Registered: 2019-10-07
Posts: 2

Re: Disable fade animation

Hey @ToZ -- it's good to be here! Thanks!

(Come to think of it, I'm sure I had an account here but it's been so many years I don't even remember the username...)

I'm reasonably sure this is the built-in Adwaita theme, but I'll check. The saturation difference isn't extreme (it's worth with other teams but I'm not going down that path...) but it's definitely there and I can see how someone could be bothered by it. It's not hard to read for you and me, on quality monitors, but for older folks on bad monitors... I've seen it, and it's not too pretty.

I've done some further digging and I think I'll settle for providing them with a package of a hacked-up Adwaita for now. It seems like the path of least resistance. If there's any interest in the community here, I can look into a real fix that everyone can benefit from.

Sorry if I was a bit grumpy about this -- I get bitter every time I have to touch GTK code nowadays. Didn't mean to take it out on you folks sad.

Offline

#9 2019-10-07 23:32:07

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,877

Re: Disable fade animation

No worries, we're pretty easy going around here.

The hacked Adwaita may be the best way to go forward. I searched for a while to see if I could find a good GTK3 theme that didn't have ":backdrop" statements, but the searches were fruitless. Even if there was one, you'd have to find some way to get everyone to change the theme. Hacking Adwaita may just be the best way forward. At one point I was thinking maybe it would be possible to create a system-wide GTK hack, but I was wrong with my assumption that /etc/gtk-3.0.gtk.css could be used. You can only use the user-based ~/.config/gtk-3.0/gtk.css file.

If you do get a working non-backdrop Adwaita theme working, post it back here. Others may find it useful.

Offline

Board footer

Powered by FluxBB