Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-07-07 09:58:58

kunzlata
Member
Registered: 2019-06-24
Posts: 40

xfconf still active after logout. Bug?

Yesterday I was making some tests in a test account and to make it simpler to restore to defaults I would log-out, delete xfce configs and caches and log back in. But I noticed that the settings weren't restored and so I logged out and as root looked for the user processes, and there were many of them, including xfce ones. To restore the defaults I had not only to delete the files but also kill all user processes before logging-in again.

So today I logged in, did almost nothing - I opened thunar and navigated to a pictures folder because yesterday I noticed that one of the remnants was tumbler, IIRC - then logged out and printed the user processes with ps.

It shows that, although there aren't any running processes, there are several active processes, including xfconf. Here's the output of 'ps -fu':

UID        PID  PPID  C STIME TTY          TIME CMD
sergio     956     1  0 06:27 ?        00:00:00 /usr/lib/systemd/systemd --user
sergio     958   956  0 06:27 ?        00:00:00 (sd-pam)
sergio     967   956  0 06:27 ?        00:00:00 /usr/bin/dbus-broker-launch --scope user
sergio     968   967  0 06:27 ?        00:00:00 dbus-broker --log 4 --controller 11 --machine-id .... --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
sergio    1018   956  0 06:27 ?        00:00:00 /usr/libexec/at-spi-bus-launcher
sergio    1023  1018  0 06:27 ?        00:00:00 /usr/bin/dbus-broker-launch --config-file=/usr/share/defaults/at-spi2/accessibility.conf --scope user
sergio    1024  1023  0 06:27 ?        00:00:00 dbus-broker --log 4 --controller 9 --machine-id .... --max-bytes 100000000000000 --max-fds 6400000 --max-matches 5000000000
sergio    1027   956  0 06:27 ?        00:00:00 /usr/lib64/xfce4/xfconf/xfconfd
sergio    1037     1  0 06:27 ?        00:00:00 /usr/bin/gpg-agent --sh --daemon --write-env-file /home/sergio/.cache/gpg-agent-info
sergio    1041   956  0 06:27 ?        00:00:00 /usr/libexec/gvfsd
sergio    1083   956  0 06:28 ?        00:00:00 /usr/libexec/gvfs-udisks2-volume-monitor
sergio    1090  1041  0 06:28 ?        00:00:00 /usr/libexec/gvfsd-trash --spawner :1.11 /org/gtk/gvfs/exec_spaw/0
sergio    1095   956  0 06:28 ?        00:00:00 /usr/libexec/gvfsd-metadata
sergio    1119     1  0 06:28 ?        00:00:00 abrt-applet --gapplication-service

Offline

#2 2019-07-07 10:33:07

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,032

Re: xfconf still active after logout. Bug?

I'm not exactly sure why that is happening (I've never come across an explanation) but you can force-kill all processes on logout using systemd's "KillUserProcesses" config parameter. Edit /etc/systemd/logind.conf and uncomment the KillUserProcesses line and set it to yes:

KillUserProcesses=yes

I believe a reboot is required.

Note that this will break any functionality that requires a session to be active after logout (e.g. tmux, screen).

Offline

#3 2019-07-07 11:44:28

kunzlata
Member
Registered: 2019-06-24
Posts: 40

Re: xfconf still active after logout. Bug?

Thanks, ToZ. Yes, maybe it's even intended behaviour, although we can't say for sure.
Anyway, people are supposed to change settings from within the session and not outside. This testing scenario isn't normal use case.

Offline

Board footer

Powered by FluxBB