Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-09-11 19:29:18

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

I am getting the message seen in the title as an error.
I have not added any new software or anything, this error just started popping up today.
A bit odd. I looked for solutions; all I found was "install unity gtk2, gtk3 module or unity module common."
I am not using unity, but worth a shot anyway. I installed the modules and all menubars on everything disappeared. I wiped the unity gtk modules back off my computer as one wipes puppy laid landmines off their shoe.

Any other ideas?

Last edited by Aravisian (2019-09-12 19:35:03)

Offline

#2 2019-09-11 20:26:28

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

Do a search for "unity-gtk-module" on your computer. Maybe there is a left-over configuration file that is still somehow active.

Also, check systemd:

systemctl --user list-units | grep module

Offline

#3 2019-09-11 23:57:44

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

ToZ wrote:

Do a search for "unity-gtk-module" on your computer. Maybe there is a left-over configuration file that is still somehow active.

Also, check systemd:

systemctl --user list-units | grep module
nrr@nrr-Aspire-V3-551:~$ locate unity-gtk-module
/home/nrr/.snap/gimp/189/.local/share/glib-2.0/schemas/com.canonical.unity-gtk-module.gschema.xml
/snap/gimp/189/usr/lib/gtk-2.0/modules/libunity-gtk-module.so
/snap/gimp/189/usr/lib/gtk-3.0/modules/libunity-gtk-module.so
/snap/gimp/189/usr/lib/systemd/user/unity-gtk-module.service
/snap/gimp/189/usr/lib/systemd/user/unity-session.target.wants/unity-gtk-module.service
/snap/gimp/189/usr/share/doc/unity-gtk-module-common
/snap/gimp/189/usr/share/doc/unity-gtk-module-common/changelog.Debian.gz
/snap/gimp/189/usr/share/doc/unity-gtk-module-common/copyright
/snap/gimp/189/usr/share/glib-2.0/schemas/com.canonical.unity-gtk-module.gschema.xml
/snap/gimp/189/usr/share/upstart/sessions/unity-gtk-module.conf

I wouldn't think having it located in a snap folder would suddenly make it an issue when I type "thunar" in terminal...

nrr@nrr-Aspire-V3-551:~$ systemctl --user list-units | grep module
sys-module-configfs.device                                                               loaded active plugged /sys/module/configfs
sys-module-fuse.device                                                                   loaded active plugged /sys/module/fuse

Offline

#4 2019-09-12 00:11:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

I wouldn't think having it located in a snap folder would suddenly make it an issue when I type "thunar" in terminal...

I agree.

I don't have any experience with or knowledge of snaps, but my guess is that is what is causing it. Perhaps it adds some setting to your startup environment that causes the message?

Offline

#5 2019-09-12 01:29:25

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

ToZ wrote:

I wouldn't think having it located in a snap folder would suddenly make it an issue when I type "thunar" in terminal...

I agree.

I don't have any experience with or knowledge of snaps, but my guess is that is what is causing it. Perhaps it adds some setting to your startup environment that causes the message?

Just to check, I uninstalled gimp through snap (snap remove gimp) and then removed residual files- the error remains.

Offline

#6 2019-09-12 01:41:16

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

Is it set in your environment?

env | grep -i module

Offline

#7 2019-09-12 03:00:37

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

ToZ wrote:

Is it set in your environment?

env | grep -i module
nrr@nrr-Aspire-V3-551:~$ env | grep -i module
CLUTTER_IM_MODULE=
GTK_MODULES=unity-gtk-module
GLADE_MODULE_PATH=:
QT_IM_MODULE=
QT4_IM_MODULE=
GTK_IM_MODULE=

nrr@nrr-Aspire-V3-551:~$ apt-cache search unity-gtk-module
unity-gtk-module-common - Common files for GtkMenuShell D-Bus exporter
unity-gtk-module-autopilot - GtkMenuShell D-Bus Autopilot tests

Offline

#8 2019-09-12 10:45:06

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,830

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

Aravisian wrote:
GTK_MODULES=unity-gtk-module

Okay, so it's being set in one of your configuration files. You just need to find which one and disable it.

Offline

#9 2019-09-12 17:29:44

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

ToZ wrote:
Aravisian wrote:
GTK_MODULES=unity-gtk-module

Okay, so it's being set in one of your configuration files. You just need to find which one and disable it.

Yeah, I have been hunting through as many configuration files as I can think of and many I cannot think of. I've scoured home folder and root folder.
Opening file after file and peering inside...

Is there no way of unsetting it from terminal or setting a new default from terminal?

Offline

#10 2019-09-12 17:52:03

Aravisian
Member
Registered: 2019-08-17
Posts: 101

Re: Gtk-Message: Failed to load module "unity-gtk-module" (Solved...)

I have learned that when I get frustrated, I should turn to Synaptic.
I searched Synaptic, then installed fcitx-modules. While at it, upgraded my kernel and then did a reboot.
Error is now gone.


Edit- Marking thread as "Solved" although I am not entirely sure what caused the problem and what solved it. A better solution/prevention may exist out there...

Last edited by Aravisian (2019-09-12 19:34:35)

Offline

Board footer

Powered by FluxBB