Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-05 22:00:56

otyugh
Member
Registered: 2015-01-11
Posts: 26

lightdm+xfdesktop + xfwm4 (with composition) = grey startup

Hey,
I'm using debian (xfwm4 : 4.12.5, lightdm : 1.26.0, xfdesktop 4.41.1).
When starting up, after lightdm, the screen is okay... But when xfdesktop (or xfwm4, I'm not sure) start for 2-20sec -depending the computer, the screen get all greyish untill xfdesktop set a wallpaper. I found out that disabling composition in xfwm4 solved that.

...And also permited to put a temporary background using feh (mxlinux uses this tricks ; setting a black&white wallpaper who will get colored when xfdesktop starts gives a great looking startup sequence).

I was wondering how to have composition enabled and avoid this ugly grey background (who let "marks" behind every object that pops, putting black marks into the greyish wallpaper. Not sexy.) startup - any clue guys ?

I found this "https://forum.xfce.org/viewtopic.php?id=8375" but it wasn't very helpful. I also found that mxlinux found a way to workaround the problem, but I have no idea how (I crawled their source quite a bit, they seem to uses compton, but even uninstalling it, mxlinux doesn't have the grey goo at the startup sequence, and composition from xfwm4 is up)



My workaround would be, I guess, to disable composition with xfconfig, wait for xfdesktop, then re-enable composition. But this is still kind of ugly, and I don't know how I could know if xfdesktop finished starting up or not - so in fact I don't have any good workaround but to disable composition alltogether.

Last edited by otyugh (2019-11-05 22:09:00)

Offline

#2 2019-11-06 00:46:38

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: lightdm+xfdesktop + xfwm4 (with composition) = grey startup

It looks alot like this ubuntu bug report. Note that the fix was 2-pronged: an xfwm4 patch and a lightdm-gtk-greeter patch.

I'm using debian (xfwm4 : 4.12.5, lightdm : 1.26.0, xfdesktop 4.41.1).

Assuming that you mean 4.14.1 for the xfdesktop version, this combination of versions is odd. You are running pre 4.14 xfwm4 but a 4.14 version of xfdesktop. Can you confirm these versions?

Also, are you using lightdm-gtk-greeter and if so, what version?

Offline

#3 2019-11-06 01:58:39

otyugh
Member
Registered: 2015-01-11
Posts: 26

Re: lightdm+xfdesktop + xfwm4 (with composition) = grey startup

ToZ wrote:

Assuming that you mean 4.14.1 for the xfdesktop version, this combination of versions is odd.

I had to download an earlier version of xfdesktop (from sid sources) to get functionalities that were broken in the stable debian release (to be exact the xfdesktop 4.12.4 break thunar's custom actions on the desktop). Maybe the problem comes from here ? I do confirm that this is the case, but if I have to backport more to get a consistent xfce environement, I would.

Also, are you using lightdm-gtk-greeter and if so, what version?

yup 2.0.6-1

Last edited by otyugh (2019-11-06 02:00:38)

Offline

#4 2019-11-06 02:04:02

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,969

Re: lightdm+xfdesktop + xfwm4 (with composition) = grey startup

I do confirm that this is the case, but if I have to backport more, I can.

I don't think backporting is a good long-term plan. What functionalities are broken for you in xfdesktop 4.14?

Offline

#5 2019-11-06 09:50:26

otyugh
Member
Registered: 2015-01-11
Posts: 26

Re: lightdm+xfdesktop + xfwm4 (with composition) = grey startup

I don't think backporting is a good long-term plan.

I totally agree. I hate to do this.

What functionalities are broken for you in xfdesktop 4.14?

Thunar's custom actions

https://forum.xfce.org/viewtopic.php?id=12491

The Thunarx API, the one that provides these menu items,  was updated in Thunar 1.8. xfdesktop relies on the Thunarx API to display those items. Unfortunately, xfdesktop's support of the newer Thunarx API doesn't appear until xfdesktop version 4.13.2.

So basically, you need an updated version of xfdesktop to display those menu entries.

I notified debian about this, but I guess things were frozen already. And that's a shame, I use custom action a looot. Convert videos/audios to mp3, convert images on the fly, optimise pdf... Got a lot of tiny things that saves time. And I do theses thing mostly on my "working area" which is the desktop. sad

EDIT : upgrading xfwm4 corrects that. Okay. Amh. This makes a lot of backported stuff. Godammit debian. hmm

EDIT2 : okay, I MXlinux was backporting them too, they had a separate repo.... Well. I don't know what to do. Seems like there is no good choice from there hmm

Last edited by otyugh (2019-11-06 21:22:18)

Offline

Board footer

Powered by FluxBB