Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-22 18:23:48

callmejoe
Member
Registered: 2019-11-19
Posts: 5

display does not turn off

using xfce 4.14 on arch.  my screen will not go blank as set in the Power Manager.

can't figure out why. any idea on where to look first?

b0tGjzq.png

and i dont have a screensaver active

kYhFCeV.png

Offline

#2 2019-11-22 23:20:07

The Loko
Member
Registered: 2015-01-23
Posts: 9

Re: display does not turn off

Is it a laptop or external display? If the latter, what graphics driver are you using?

The output of the following commands could be useful too:

xfce4-power-manager --dump
xfconf-query -c xfce4-power-manager -lv
xset -q

Offline

#3 2019-11-23 01:07:54

callmejoe
Member
Registered: 2019-11-19
Posts: 5

Re: display does not turn off

external display

graphics driver

Graphics:  Device-1: AMD Curacao PRO [Radeon R7 370 / R9 270/370 OEM] driver: radeon 
           v: kernel 
           Display: server: X.Org 1.20.5 driver: radeon 

xfce4-power-manager --dump

---------------------------------------------------
       Xfce power manager version 1.6.5
With policykit support
Without network manager support
---------------------------------------------------
Can suspend: True
Can hibernate: True
Authorized to suspend: True
Authorized to hibernate: True
Authorized to shutdown: True
Has battery: False
Has brightness panel: False
Has power button: True
Has hibernate button: True
Has sleep button: True
Has battery button: True
Has LID: False

xfconf-query -c xfce4-power-manager -lv

/xfce4-power-manager/blank-on-ac                    30
/xfce4-power-manager/dpms-enabled                   true
/xfce4-power-manager/dpms-on-ac-off                 0
/xfce4-power-manager/dpms-on-ac-sleep               0
/xfce4-power-manager/lock-screen-suspend-hibernate  false
/xfce4-power-manager/show-tray-icon                 false

xset -q

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  526    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  no    allow exposures:  no
  timeout:  840    cycle:  840
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/100dpi,/usr/share/fonts/75dpi,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

Offline

#4 2019-11-25 21:33:43

The Loko
Member
Registered: 2015-01-23
Posts: 9

Re: display does not turn off

callmejoe wrote:
Screen Saver:
  prefer blanking:  no

This seems to be the culprit.
Something is disabling the blanking and XFCE power manager ignores that setting.
It can be enabled with:

xset s blank

And disabled with:

xset s no blank

Maybe you have another power manager with different settings?

The quick (and maybe dirty) fix is to add the blanking enable command to Session and Startup > Application Autostart > Add new
Then you could check with xset q if the blanking is enabled.

Offline

Board footer

Powered by FluxBB