Xfce Forum

Sub domains

You are not logged in.

#1 2006-10-03 17:17:10

Registered: 2006-10-03
Posts: 2

Got a configure problem on Debian

Hi, all

I'm using a Debian system and use the graphical installer to install xfce4, I download a bin file from os-cillation.com, which is xfce4-4.4RC1-installer.run. And the installer works right. According to the installation document I've installed the package libgtk2.0-dev, libice-dev, libsm-dev and libxpm-dev.
I also looked through http://www.tuxme.com/node/358 and installed the packages mentioned.

But when the installer is configuring libxfce4mcs it shows an error.

checking for X... no
configure: error: X Window system libraries and header files are required
!! Failed to configure libxfce4mcs, see the errors above
!! for details on the problem.

Then I installed x-windows-system and checked for available x libraries and headers but find nothing. The problem still exists. I'm running on gnome now. How can it reports no X?

Hope you can help. Thanks.


#2 2006-10-03 17:53:16

Registered: 2006-10-03
Posts: 2

Re: Got a configure problem on Debian

SOLVED!  I find the solution in the following post.

and use the following command first:
apt-get build-dep libxfce4mcs

Then the problem is solved.
Sorry I did not search. Thanks.


Board footer

Powered by FluxBB