Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-05-04 17:25:15

mbokil
Member
Registered: 2004-11-24
Posts: 9
Website

Nautilus launches when USB drives inserted

I have been having a problem where Nautilus launches when USB drives are inserted. I figured out how to disable this option in gconf-editor. I set volume_manager autobrowse to Off. I was looking at how I could change the autobrowse command to Thunar. I actually looked through the source code for volume-manager and found:

#define NAUTILUS_COMMAND "/usr/bin/nautilus -n --no-desktop %m"

Ugh, it is currently hard coded! It looks like a patch will have to be supplied to fix this problem for XFCE4 and other DEs.


Author of: MenuX Firefox extension, MonkeyMenu Seamonkey extension, SeaFox GTK theme, and Volume Desklet
Cats rule!

Offline

#2 2007-05-06 19:16:14

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Nautilus launches when USB drives inserted

Why don't you disable Nautilus and install thunar-volman and run thunar as a daemon on desktop startup?

Offline

Board footer

Powered by FluxBB