Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-06-22 03:53:57

tim042849
Member
From: Palmer, Alaska
Registered: 2007-06-20
Posts: 21

Keyboard Settings → Shortcuts: appears to be disabled

Following the instructions in the FAQ at http://wiki.xfce.org/faq,
under the heading "Usage, Keyboard, Is there some way to call the menu with the keyboard in the xfce?"
I right-click on the desktop, choose "settings->Keyboard Settings"
A dialogue box titled: "Keyboard Preferences" pops up.
I then choose the "Shortcuts" tab and I see four items there, including the
xfce4-popup-menu item, which *appears* to be mapped to control-escape.
However, all items are "grayed out" and are not configurable, what's more
- the control-escape key does not bring up the popup menu. In addition,
xfdesktop -menu is not available at all.

I appear to be looking in the wrong place for my needs - I want to do as
much keyboard mapping as possible for xfce resources.

Can someone point me to the correct documentation or advise me on
how to configure keyboard settings for xfce.
I'm using ubuntu 7.04 amd 64.

thanks
tim

Offline

#2 2007-06-22 05:30:16

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Keyboard Settings → Shortcuts: appears to be disabled

What you see (greyed out) are the settins of teh default keyboard which you cannot change or add to. What you can do is add another keyboard definition (Add in the left pane of same screen) and then add some keyboard definitions.

Offline

#3 2007-06-22 16:09:57

tim042849
Member
From: Palmer, Alaska
Registered: 2007-06-20
Posts: 21

Re: Keyboard Settings → Shortcuts: appears to be disabled

Got it.
I can create a new layout, and I can edit or add commands,
but I can't find out how to assign a shortcut. If I double-click
under "shortcuts", the resulting popup only allows me to
cancel or choose "No shortcut".
Thanks
tim

Offline

#4 2007-06-23 00:08:12

tim042849
Member
From: Palmer, Alaska
Registered: 2007-06-20
Posts: 21

Re: Keyboard Settings → Shortcuts: appears to be disabled

I find that I can manually edit ~/.config/xfce4/shortcuts/Tims.xml
Now I'd like to get the command names - I find that something
like ls /usr/bin/xfc* shows me many xfc-specific commands.

However, coming from KDE where things are a bit obfuscated,
I now need to find command names for things like:
"Walk thru windows"
"walk thru desktops"
"show taskmanager"
"show window list"
"show clipboard popup"
NOTE: I'm paraphrasing KDE terms...
Any suggestions and comments are appreciated, and I will be
researching documentation in the meantime.
thanks
tim

Offline

#5 2007-06-23 06:19:08

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Keyboard Settings → Shortcuts: appears to be disabled

I am not sure that XFCE and kDE allow the same set of events to be controlled by keyboard. In other words: some of the commands you are looking for to assign to keys may not exist in XFCE. Suggest you create a keyboard for yourself (if not yet done) and then look in ~/.themes/keyboardname/xfwm4/keythemerc to see what is all possible.

Offline

#6 2007-06-24 01:14:02

tim042849
Member
From: Palmer, Alaska
Registered: 2007-06-20
Posts: 21

Re: Keyboard Settings → Shortcuts: appears to be disabled

Hi:
I'm not having success doing this:
I tried two methods:
1)Instructions at http://www.osnews.com/story.php/7002/Gi … pin/page3/
"""
$ mkdir -p ~/.themes/xfwm4/custom.keys/
$ cp /usr/share/xfwm4/themes/default.keys/keythemerc ~/.themes/xfwm4/custom.keys/
$ vim ~/.themes/xfwm4/custom.keys/keythemerc
Then open the window manager settings dialog, go to the 'keyboard and focus' tab and choose your new key theme.
"""
Result: Opened Window Manager
Keyboard and Focus tabs are separate - BTW: I'm using version 4.4
No sign of any keyboard *but* "default", I would expect one called "custom".
2)Secondly, tried this method:
Under the Keyboard Tab, Left Pane, clicked on the "+" button.
Got dialogue Box titled: "Add Keybinding Theme"
Put the title: "Tims" in the box with label: "Enter a Name for the Theme"
Click "OK".
Nothings happens!
:?
Any other ideas?
Do I have a buggy version?
*OR*, should the theme file be at another path than the one
above, for my version?
thanks for the input so far.
tim

Offline

#7 2007-06-24 15:37:27

tim042849
Member
From: Palmer, Alaska
Registered: 2007-06-20
Posts: 21

Re: Keyboard Settings → Shortcuts: appears to be disabled

What a difference a day makes.
After rebooting xfce a couple of times, I'm happy to report
that the window manager is picking up ~/.themes/xfwm4/custom.keys/keythemerc
as keyboard "custom" and I can now modify keys.
Which is a good thing, because some the bindings would
interfere with emacs.

Thanks very much to Pindakoe
cheers
tim

Offline

Board footer

Powered by FluxBB