Xfce Forum

Sub domains
 

You are not logged in.

#1 2008-11-10 22:29:59

olympia
Member
Registered: 2008-03-22
Posts: 5

Configuration of xfce4-xkb-plugin

Hi,
how do I have to configure xfce4-xkb-plugin to switch between german and french keyboards?
Using debian lenny, X.Org X Server 1.4.2
Thanks, Klaus

Offline

#2 2008-11-11 01:13:55

eriefisher
Member
Registered: 2008-10-25
Posts: 51

Re: Configuration of xfce4-xkb-plugin

You first need to edit your /etc/X11/xorg.conf so you have the options available.

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc101"
    Option        "XkbLayout"    "us"

change or add to the XkbLayout line to reflect the language you need, Mine shows "us", I think German is "de" and french is "fr" so it would be "dr,fr".

Offline

#3 2008-11-11 18:04:49

olympia
Member
Registered: 2008-03-22
Posts: 5

Re: Configuration of xfce4-xkb-plugin

Tried that already.

Setting

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "de,fr"
        Option          "XkbVariant"    "nodeadkeys"
EndSection

I get "aze¶ŧy" instead of "azerty" with the french setting.

Strange enough, if I set "de,fr,us", it seems, all three layouts are ok, but the "nodeadkeys" option does not work any more with the german layout, which I need especially for "~" using the shell.

The README tells us, that

The plugin itself cannot be used for defining the keyboard
layouts one wants to use, this is done the XKB way - either
in XF86Config or by xetskbmap tool.

(which should read setxkbmap, cf. http://bugs.debian.org/cgi-bin/bugrepor … ug=445335).

The question is, how can I configure the plugin to use setxkbmap.

Offline

Board footer

Powered by FluxBB