Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-12-29 00:38:01

outlaw
Member
Registered: 2005-02-06
Posts: 21

[Solved] Notes Dependancy

Just tried to build the notes plugin from source and received the following error message from configure:

checking for unique-1.0 >= 1.0.0... not found

I can usually firgure out what package is missing using synaptic in Debian (lenny) ... not this time.

Any suggestions would be much appreciated.

Thanks

Offline

#2 2009-12-29 02:59:10

outlaw
Member
Registered: 2005-02-06
Posts: 21

Re: [Solved] Notes Dependancy

Well the problem was that the package did not exist in the debian repository lenny had to download from squeeze.

Now the next problem is when executing make: undefined reference to `gtk_widget_set_can_focus

I'm thinking that probably I need to upgrade the gtk toolset which might pooch the system ...

Comments are welcome

Offline

#3 2009-12-29 04:27:31

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: [Solved] Notes Dependancy

* libgtk+2 2.10
* libxfce4panel 4.4.0
* libxfcegui4 4.4.0
* xfconf 4.6.0

Thats from the README in the git root of Mikes project, and he's usually pretty good at keeping that sorta stuff upto date.  Have all the requirements?  I'd almost bet you've got 2.10 or better (probably way better hah).  What version of GTK+ do you have installed?

Offline

#4 2009-12-29 12:17:10

outlaw
Member
Registered: 2005-02-06
Posts: 21

Re: [Solved] Notes Dependancy

Well the information provided from apt-get is ...
Package: libgtk2.0-0
Version: 2.12.12-1 ~lenny

Not sure that upgrading the gtk libs would be in the best interest of my main system smile

Thanks for the input

Offline

Board footer

Powered by FluxBB