Xfce Forum

Sub domains
 

You are not logged in.

#1 2010-09-18 00:54:12

CoolnessItself
Member
Registered: 2010-09-18
Posts: 3

Starting terminal in user account fails

Hi all,
I just put xfce on my newly compiled X. When root is logged in,
startx
Works just fine, and xfce loads, and rclick>terminal works.
When in a user account, startx (runs startxfce4 in bashrc) gives a few errors that you can't see in time but you get a desktop.  rclick>terminal says xserver already running then you're back in the console.

Any idea why this would happen?
(4.6.2)

Offline

#2 2010-09-19 02:51:44

CoolnessItself
Member
Registered: 2010-09-18
Posts: 3

Re: Starting terminal in user account fails

A clarification with some more log files:



Here is
su ME -c startxfce4 > out.txt

/usr/bin/startxfce4: Starting X server


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.34-gentoo-r6 x86_64
Current Operating System: Linux ME 2.6.34-gentoo-r6
Kernel command line: root=/dev/sda7
Build Date: 17 September 2010  01:22:56PM

Current version of pixman: 0.18.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Sep 18 19:45:14 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) [KMS] Kernel modesetting enabled.
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft
xrdb:  "Xft.hinting" on line 9 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 11 overrides entry on line 7
Agent pid 7181

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/security/EnableTcp" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchGNOME" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchKDE" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/chooser/AlwaysDisplay" does not exist on channel "xfce4-session"
xfdesktop[7204]: starting up

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat" does not exist on channel "keyboards"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat/Delay" does not exist on channel "keyboards"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/xinerama-stretch" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/KeyRepeat/Rate" does not exist on channel "keyboards"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/style" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/icon-size" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/StickyKeys" does not exist on channel "accessibility"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/font-size" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/SlowKeys" does not exist on channel "accessibility"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/use-custom-font-size" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/BounceKeys" does not exist on channel "accessibility"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/MouseKeys" does not exist on channel "accessibility"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color-style" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color1" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color2" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-show" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-style" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/saturation" does not exist on channel "xfce4-desktop"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/XkbDisable" does not exist on channel "keyboard-layout"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/NumScreens" does not exist on channel "displays"

(xfce4-settings-helper:7206): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/NumScreens" does not exist on channel "displays"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-filesystem" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-home" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-trash" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-removable" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-menu/show" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-workspace-names" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-submenus" does not exist on channel "xfce4-desktop"

(xfdesktop:7204): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-sticky-once" does not exist on channel "xfce4-desktop"

(xfce4-panel:7201): libxfcegui4-WARNING **: ICE I/O Error

(xfce4-panel:7201): libxfcegui4-WARNING **: Disconnected from session manager.
xfce4-panel-Message: Xfce4-panel already running

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/AutoSave" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/PromptOnLogout" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/shutdown/ShowSuspend" does not exist on channel "xfce4-session"

(xfce4-session:7189): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/shutdown/ShowHibernate" does not exist on channel "xfce4-session"

I get a desktop, but when I rclick>Terminal, I'm pretty sure it says
[something about X already running]
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft

and then terminal closes.

Offline

#3 2010-09-19 07:45:47

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Starting terminal in user account fails

Not quite sure that I see the cause, but I do note that you start X as root. What happens if you do 'startxfce' when logged in as normal user?

Offline

#4 2010-09-19 16:02:05

CoolnessItself
Member
Registered: 2010-09-18
Posts: 3

Re: Starting terminal in user account fails

I did that so I could save the error messages.
root by itself works fine. I can get a terminal.

in user, I get a desktop, but rclick terminal closes the terminal as soon as it opens. I don't have time to read anything, but something about
[something about X already running]
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft
appears

When logging out, I see the same xconf-warnings in my previous post

Offline

Board footer

Powered by FluxBB