Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-03-21 23:13:43

chino_black
Member
Registered: 2012-02-02
Posts: 3

Unable to find or create trash directory

hello

when trying to delete a file from a mounted ntfs partition with ntfs-3g gives me the following error "Unable to find or create trash directory"

I use fedora 16 with xfce 4.8

Greetings.

Offline

#2 2012-03-22 17:10:58

hansi999
Member
Registered: 2012-03-22
Posts: 1

Re: Unable to find or create trash directory

Hi,

exactly the same here. (archlinux)
Tried to change the permissions of .Trash folders, but its still not working.

regards,
hansi

Edit:
Ups, i have the problem with NFS mounts, i should improve my reading skills. :-(

Last edited by hansi999 (2012-03-23 15:48:05)

Offline

#3 2012-03-22 21:40:22

daggoth
Member
From: New Zealand
Registered: 2009-03-05
Posts: 42

Re: Unable to find or create trash directory

Could this be because fat/ntfs filesystems don't support the same permissions used by linux filesystems like ext4? Files on ntfs/fat typically obtain their user/group properties from the mount options that you provide. I'm just guessing, but if this is your problem, then it is mentioned here.

Offline

#4 2012-03-23 18:51:19

chino_black
Member
Registered: 2012-02-02
Posts: 3

Re: Unable to find or create trash directory

not working sad

Offline

#5 2012-03-27 00:38:39

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: Unable to find or create trash directory

In fstab :
LABEL=Data  /mnt/data  ntfs-3g  defaults,umask=077,uid=1000,gid=100,users,exec,noauto,noatime 0 0

The important parts being umask, uid and/or gid.

Offline

#6 2012-04-26 14:00:27

Math.
Member
Registered: 2012-04-26
Posts: 3

Re: Unable to find or create trash directory

Creating a .Trash-1000 folder in the root of your mounted ntfs partition will fix this.

Offline

#7 2012-04-29 06:12:39

gymka
Member
From: Lithuania
Registered: 2012-01-07
Posts: 20
Website

Re: Unable to find or create trash directory

stqn wrote:

In fstab :
LABEL=Data  /mnt/data  ntfs-3g  defaults,umask=077,uid=1000,gid=100,users,exec,noauto,noatime 0 0

The important parts being umask, uid and/or gid.

i had simillar problem with deluge(it said that can't reach files), adding "uid" and "gid" to fstab line helped.

Offline

Board footer

Powered by FluxBB