Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-09-13 10:23:07

user999
Member
Registered: 2012-09-13
Posts: 8

[Solved] How to make Xfwm "arrow" button disappear?

I am using Debian wheezy with Xfwm 4.8.3.

Any help would be appreciated!

Off topic: Xfce does not lock the screen when going to sleep or hibernate, even though I checked that in the power management settings. Any info on this before I file a bug to debian?


Debian wheezy with Xfwm 4.8.3

Offline

#2 2012-09-13 12:10:05

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

Settings>Window Manager and choose the button layout you want.

As for the bug, I've heard about that before but since I don't have that set up here I can't confirm. Try searching the net for it (and Xfce bugzilla too).

Offline

#3 2012-09-13 17:22:08

user999
Member
Registered: 2012-09-13
Posts: 8

Re: [Solved] How to make Xfwm "arrow" button disappear?

secipolla wrote:

Settings>Window Manager and choose the button layout you want.

As for the bug, I've heard about that before but since I don't have that set up here I can't confirm. Try searching the net for it (and Xfce bugzilla too).

Thank you very much!


Debian wheezy with Xfwm 4.8.3

Offline

#4 2012-09-13 22:58:12

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

I got a clue now about the failure to lock the screen.
Xfce currently has an issue of having more than one place to set the same thing and that may be confusing.
In the case of locking the screen when going to sleep it can be set both in the power manager and in Settings>Session and Startup, so try setting it in both (specially the latter).
Just to mention, a similar issue is that icons can be disabled for application menus in the appearance settings and that disables icons for the panel menu too even if it's set to show icons in its own properties.

Offline

#5 2012-09-14 17:10:00

user999
Member
Registered: 2012-09-13
Posts: 8

Re: [Solved] How to make Xfwm "arrow" button disappear?

secipolla wrote:

I got a clue now about the failure to lock the screen.
Xfce currently has an issue of having more than one place to set the same thing and that may be confusing.
In the case of locking the screen when going to sleep it can be set both in the power manager and in Settings>Session and Startup, so try setting it in both (specially the latter).
Just to mention, a similar issue is that icons can be disabled for application menus in the appearance settings and that disables icons for the panel menu too even if it's set to show icons in its own properties.

Strange, I could not find any lock screen related options in Sessions and Startup.
Which distro are you using?

Good evening!


Debian wheezy with Xfwm 4.8.3

Offline

#6 2012-09-14 18:10:46

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

I'm on Fedora 17. I guess it's something new to Xfce 4.10 then.

Anyway, I remember reading other posts about folk having issues with this feature. And if you want 4.10 in wheezy, it seems it's in the experimental repository (probably only didn't come to wheezy because of the freeze process).

Last edited by secipolla (2012-09-14 18:12:44)

Offline

#7 2012-09-15 06:39:51

user999
Member
Registered: 2012-09-13
Posts: 8

Re: [Solved] How to make Xfwm "arrow" button disappear?

secipolla wrote:

I'm on Fedora 17. I guess it's something new to Xfce 4.10 then.

Anyway, I remember reading other posts about folk having issues with this feature. And if you want 4.10 in wheezy, it seems it's in the experimental repository (probably only didn't come to wheezy because of the freeze process).

I would rather wait for a fix. Thanks for your help!


Debian wheezy with Xfwm 4.8.3

Offline

#8 2012-09-17 15:27:22

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

Just to add, if the power manager is using xflock to lock the screen you need xscreensaver, xlockmore or slock, I think, for it to work.
I read that there's a xdg-screensaver command that should recognize other screen-lockers but I don't know if it really does so and if xfce4-power-manager is compatible with it.

Offline

#9 2012-10-16 14:39:42

user999
Member
Registered: 2012-09-13
Posts: 8

Re: [Solved] How to make Xfwm "arrow" button disappear?

Does anybody happen to know how to disable this reduce-window-to-title-bar function altogether?

(Accidentally rolling up my mouse button easily activates this thing...)

Last edited by user999 (2012-10-16 14:41:23)


Debian wheezy with Xfwm 4.8.3

Offline

#10 2012-10-16 15:34:57

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

I don't know, but maybe that function should be in the window manager keyboard shortcuts so it could be changed/disabled.
Maybe you could open a bug report asking for that?

Offline

#11 2012-10-16 19:01:20

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 950

Re: [Solved] How to make Xfwm "arrow" button disappear?

This works for me:

xfconf-query -c xfwm4 -p /general/mousewheel_rollup -s false

Offline

#12 2012-10-17 00:41:25

user999
Member
Registered: 2012-09-13
Posts: 8

Re: [Solved] How to make Xfwm "arrow" button disappear?

ToZ wrote:

This works for me:

xfconf-query -c xfwm4 -p /general/mousewheel_rollup -s false

Worked perfectly, thank you ToZ very much!!!
Thanks secipolla too!

I planned to switch over to Gnome3 "Debian flavor" (Redhat shipped with Gnome3 that I found quite unusable).
However it seems that the Xfce forum community really lives! I will likely stay with Xfce smile


Debian wheezy with Xfwm 4.8.3

Offline

#13 2012-10-17 20:18:26

demosthenese
Member
From: Liverpool, UK
Registered: 2009-05-04
Posts: 62

Re: [Solved] How to make Xfwm "arrow" button disappear?

secipolla wrote:

Just to add, if the power manager is using xflock to lock the screen you need xscreensaver, xlockmore or slock, I think, for it to work.

xflock4 is just a bash script - so you can easily edit it to add other screen-lockers.

I use xtrlock so I added xtrlock to the list of lockers to check for.

#!/bin/sh
#
#  xfce4
#
#  Copyright (C) 1999, 2003 Olivier Fourdan (fourdan@xfce.org)
#  Copyright (C) 2011       Guido Berhoerster (guido+xfce.org@berhoerster.name)
#  Copyright (C) 2011       Jarno Suni (8@iki.fi)
#
#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.
#
#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.
#
#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#

PATH=/bin:/usr/bin
export PATH

# Lock by xscreensaver or gnome-screensaver, if a respective daemon is running
for lock_cmd in \
    "xscreensaver-command -lock" \
    "gnome-screensaver-command --lock"
do
    $lock_cmd >/dev/null 2>&1 && exit
done

# else run another access locking utility, if installed
for lock_cmd in \
  "xlock -mode blank" \
  "slock" \
  "xtrlock"
  do
    set -- $lock_cmd
    if command -v -- $1 >/dev/null 2>&1; then
        $lock_cmd >/dev/null 2>&1 &
	# turn off display backlight:
	xset dpms force off
        exit
    fi
done

# else access locking failed
exit 1

Last edited by demosthenese (2012-10-17 20:21:30)

Offline

#14 2012-10-17 22:35:30

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: [Solved] How to make Xfwm "arrow" button disappear?

Thank for that! I'm using i3lock.
I never thought it was a script.

Offline

Board footer

Powered by FluxBB