Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-04-08 22:01:16

markfilipak
Member
Registered: 2013-03-11
Posts: 46

How can I lock the display at 1395x847?

Hi All,

I'm not being very successful finding things on my own -- Thunar cooking file names doesn't help!  ;-(

How can I lock the display at 1395x847?

I found where to set the screen size of course. I just don't know how to lock it.

Thanks much - Mark.

Last edited by markfilipak (2013-04-08 22:02:43)


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

#2 2013-04-09 09:23:43

Sloth
Member
Registered: 2013-04-06
Posts: 10

Re: How can I lock the display at 1395x847?

Browse to

~/.config/xfce4/xfconf/xfce-perchannel-xml

In the "displays.xml" file, set the resolution and then reboot or restart gdm.

Offline

#3 2013-04-09 16:06:36

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Re: How can I lock the display at 1395x847?

Thanks for that, Sloth, but it's already set.

Background: Xfce is inside a VM. As the VM boots, Xfce changes the resolution automagically. At the end of the boot, resolution is left a 1024x768. I need to lock it at 1395x847 so that Xfce can't change it, so at the end, it's right.

I'm very new to Linux, but...

Candidate Solutions:

1 - Since the Settings Editor shows what looks like boxes used to lock each particular setting (at least, the column is labeled "Locked"), I assume there must be a way to lock 'displays', 'Default', 'Virtual1', 'Resolution' because there's a "Locked" box. If the problem is privileges, then I could 'sudo <settings-editor>' except I don't know the name and path to the Settings Editor.

2 - I could 'sudo gedit ./displays.xml' as you suggest, but if there's a way to lock 'resolution', 'displays.xml' doesn't give a clue. Ah! I just had a brainwave: I just added a 'locked="true"' attribute to the 'resolution' tag... and now my Linux VM won't boot. ARGH! It's hung displaying "Starting the Desktop Manager".

Well, I've got a lot bigger problem now.


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

#4 2013-04-09 17:18:17

markfilipak
Member
Registered: 2013-03-11
Posts: 46

Re: How can I lock the display at 1395x847?

Hahahahahahahahahah... You're not going to believe this: I got the booting display to 'unhang' by forcing the VM into full-screen mode.

Oh, my! I just fired up 'Settings Editor' and for the 'displays' channel, I see this:

Default     Empty    [_]
  Virtual   String   [_]   Virtual1
    Active  Boolean  [_]   [v]

everything below that is ...GONE!

Okay... I returned the contents of 'displays.xml' to its original state and rebooted. All is back to 'usual' ...whew! I dodged a bullet there.

After I boot, the VM's window-frame (inside MS-Windows) is maximized (1394x900). Inside that is the Linux Mint + Xfce display. It is 1024x768. If, at this early point, I force the Xfce display to redraw (if I fiddle with the VM), the Xfce display pops out to the full 1394x847 and all is joy. BUT, if I don't fiddle with the VM and just look at the 'Resolution' in 'displays.xml', it says '1394x847' but the actual display is 1024x768.

I would say that, at the end of display initialization, Xfce should refresh the display one more time.

In the mean time, I'll just have to live with the current behavior.

Thanks, Sloth, I'm going to give up and file this as an 'enhancement'.

Last edited by markfilipak (2013-04-09 17:19:59)


VMware Player 5.0.2
Host: WinXP3, 32-bit
Guest: Linux Mint 14, 64-bit + Xfce 4.10

Offline

Board footer

Powered by FluxBB