Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-09-04 11:45:15

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

System time changes every time I restart the machine.

Hi,

This is a copy of a question I posted on the Fedora forum.


I have Fedora release 18 (Spherical Cow) 3.9.4-200.fc18.x86_64 with XFCE 4.10. Every time I restart the computer the time changes by one hour forward. For example it is

Wed, 04 Sep 2013 10:18:22 +0100

instead of:

Wed, 04 Sep 2013 9:18:22 +0100

I then correct it with:

sudo date --set="Wed, 04 Sep 2013 9:18:22 +0100"

but after the reboot it reverts to the incorrect setting.

The time in the BIOS is correct. My locale is correct too:

LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

I don't have ntpd running:

$ service ntpd status
Redirecting to /bin/systemctl status  ntpd.service
ntpd.service - Network Time Service
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; disabled)
   Active: inactive (dead)

How do I go about troubleshooting such problem [in XFCE]?

Offline

#2 2013-09-04 12:55:11

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 265

Re: System time changes every time I restart the machine.

One hour exactly? Could it have something to do with a daylight savings time setting?

Regards,
MDM

Offline

#3 2013-09-04 14:04:22

king-ghidorah
Member
Registered: 2013-04-19
Posts: 16

Re: System time changes every time I restart the machine.

It had indeed. It was windows messing with the hardware clock and then linux thinking that the clock used UTC. Nothing to do with XFCE.

More info in the Fedora forum's thread.

Thanks beer.gif

Offline

Board footer

Powered by FluxBB