Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-10-09 08:25:44

gojira
Member
Registered: 2012-11-20
Posts: 9

[Solved] Prevent target application of "Open with" to jump the virtual desktop

I hover with the mouse pointer over a file in Thunar 1.4.0.
I right click and select Open With -> Open With "Geany".
Geany is on another Workspace of the Virtual Desktop Manager of Xfce.
The file then opens in Geany, but at the same time Geany get's warped from the virtual desktop where it was, to the virtual deskptop where I am doing this.

I find this extremely annoying. How can I swith this off? I want Geany to stay on the virtual desktop where it was.

This problem persists will all other programs where I used it.

--
I use:
Thunar 1.4.0
Geany 1.22
Xfce Version 4.10 Distributed by Xubuntu
Xubuntu don't know which version and don't know how to check the version

Offline

#2 2013-10-09 10:16:47

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,127

Re: [Solved] Prevent target application of "Open with" to jump the virtual desktop

Settings Manager -> Window Manager Tweaks -> Focus tab, change the "When a window raises itself" option to something not "Bring window on current workspace".

Offline

Board footer

Powered by FluxBB