Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-01-03 02:50:20

mpan-tmp-6da33dd1
Member
Registered: 2014-01-03
Posts: 3

[Solved] [Mail Watcher] Indicator stuck in "new mail" icon

I have configured the Mail Watcher plugin for my POP3 account. After the first check it find few hundreds new messages on my account and the indicator shows "new mail" icon (the yellow one). This is fine, as for the first run it should detect all messages as new. However the yellow icon never goes back to gray. It's stuck in this state forever.

What am I doing wrong? There is almost no options in the plugin, so I don't think I've missed something. Where is my mistake?


This is a temporary account. It may go inactive after this issue is resolved.

Offline

#2 2014-01-03 15:49:00

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 311

Re: [Solved] [Mail Watcher] Indicator stuck in "new mail" icon

Did you mark each and every one of those hundreds of emails as "read" - or delete them - before that panel applet performed another check? My first guess is, "No, and so the applet still considers them to be 'new' emails."

But I could be wrong; it's been a while since I've dealt with POP3 accounts, because I've been known to use multiple devices for email.


Btw, feel free to make your "temporary"account "permanent," and stay a while.

Regards,
MDM

Offline

#3 2014-01-03 16:01:59

mpan-tmp-6da33dd1
Member
Registered: 2014-01-03
Posts: 3

Re: [Solved] [Mail Watcher] Indicator stuck in "new mail" icon

POP3 doesn't support read status. Unlike with IMAP it's only client-side. However, just to make things clear: all of the mails were read before I've first run Mail Watcher. And new mails are read too.

None of the mails is removed from the server, but this should not affect anything. However, when you have mentioned this, I've realized that I can't even find any means of marking the mails as read in Mail watcher. How to do this? In mail-notification it was enough to click notification icon. In Mail Watcher I see nothing that does that - I've tried clicking, searching through the menus... nothing.

Also when I remove an email... the applet detected this as a new mail too.

Thanks for the invitation. Be sure that if I'll consider joining the forum for longer, I'll make a permanent account.


This is a temporary account. It may go inactive after this issue is resolved.

Offline

#4 2014-01-09 18:30:15

mpan-tmp-6da33dd1
Member
Registered: 2014-01-03
Posts: 3

Re: [Solved] [Mail Watcher] Indicator stuck in "new mail" icon

I've checked the sources and the mystery is solved.

If anyone got stuck with the same problem, here is the answer: there is no POP3 support at all. The implementation fakes it by returning total number of messages in the mailbox. Hence on the first run Mail Watcher reports proper value (all messages are new) and it looks like it is working. But then it will be stuck in this state forever, occasionally reporting new mails every time number of messages changes because actually a new mail has arrived or old one was deleted.


This is a temporary account. It may go inactive after this issue is resolved.

Offline

Board footer

Powered by FluxBB