Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-01-06 18:43:52

Kordo
Member
From: France
Registered: 2014-01-04
Posts: 5
Website

[Solved] system-config-language not showing in Applications menu>Administration

With  Freed-ora 19(Fedora/Libre)i run my system in English or French
I just ran :yum install system-config-language.

I then could access throught >Administration>Language.and make changes very easily/french/english..

On Free-dora 20 >Applications Menu>Administration>Language>I just get the Supersuser password asked but
the GUI doesn't open up after password entered.

I have worked around that with :yum install-system-config-language
                                              system-config-language(which opened another Gui in the terminal)

Anyway of having the GUI back on the> Application Menu>Administration>Language?(was there in Freedora19)

Thanks!;-)

Last edited by Kordo (2014-01-06 18:46:43)

Offline

#2 2014-01-07 01:20:44

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 189
Website

Re: [Solved] system-config-language not showing in Applications menu>Administration

I just tested on Korora 20 (also a Fedora remix) and it works fine for me. Do you get any messages in the terminal when you start it?
As you are running immediately after installing I'm guessing you are running it as root. What happens when you try to run it from a terminal as a user? Any errors, messages etc.?

Offline

#3 2014-01-07 11:59:53

Kordo
Member
From: France
Registered: 2014-01-04
Posts: 5
Website

Re: [Solved] system-config-language not showing in Applications menu>Administration

Thanks Ozjd ;-)
https://docs.fedoraproject.org/en-US/Fe … board.html

Basically the GUI on the Applications Menu > Administration > Language will not open up after root password entered.
the only way to change Languages is with the terminal:

[root@localhost ~]# system-config-language
Starting graphical mode failed.  Starting text mode instead.
Loaded plugins: langpacks
The a GUI open's in the""Terminal""=(despite graphical mode failed?)
┌──────────┤ Language Selection ├──────────┐
                  │                                          │
                  │   Select the language for the system.    │
                  │                                          │
                  │  Danish - Dansk                        ↑ │
                  │  Dutch (Belgium)                       ▒ │
                  │  Dutch (Netherlands)                   ▮ │
                  │  English (Australia)                   ▒ │
                  │  English (Botswana)                    ▒ │
                  │  English (Canada)                      ▒ │
                  │  English (Denmark)                     ▒ │
                  │  English (Great Britain)               ↓ │
                  │                                          │
                  │       ┌─────┐              ┌────┐        │
                  │       │ Yes │              │ No │        │
                  │       └─────┘              └────┘        │
                  │                                          │
                  │                                          │
                  └──────────────────────────────────────────┘
       On Freed-ora 19 (Fedora-Libre-Kernel ) i could make changes after :Yum install system-config-language/open Applications menu > Admin > Language.
root password >select language/make change /reboot and i would be in the language selected.But it doens't work on Freed-ora 20.

Cheers!

Offline

#4 2014-01-07 21:30:41

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 189
Website

Re: [Solved] system-config-language not showing in Applications menu>Administration

There are a number of results come up when searching for that error but most are quite old. It used to require some Gnome packages but that was supposedly fixed several versions ago. It isn't clear from the error you're getting what is breaking it. Maybe a bug report on your distro would be a start.

Offline

#5 2014-01-08 09:34:04

Kordo
Member
From: France
Registered: 2014-01-04
Posts: 5
Website

Re: [Solved] system-config-language not showing in Applications menu>Administration

yes! it looks as if it breaks right after the little window with root password.
I just installed Fedora 20 on another HD & the same problem appears thus excluding a Freed-ora issue or HD corruption.
Looks like a Bug...never done a bug report yet,but will do that.
Thanks for your help & all the best to you in Australia.

Offline

Board footer

Powered by FluxBB