Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-07-31 20:07:36

jimwg
Member
Registered: 2011-12-11
Posts: 67

Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Greetings,

I am reviving a R31 Thinkpad by replacing XP with Mint Maya and XFCE. I previously had XFCE 4.10 running on other Mint installs but I'm unable to update Mint Maya from XFCE 4.08 to 4.10 (which has more desired desktop rendering features) via ppa as instructed by many Mint sites which just doesn't seem to be working, as though my Thinkpad's just sucking volumes of PPA vapor. The archives at ppa Xubuntu and what have you just aren't taking. Is there a "stand alone" deb archive of XFCE 4.10 that I can try to install myself?

Thanks for any hints!

Jim in NYC

Offline

#2 2015-08-01 00:26:56

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,876

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Why don't you install a newer version of Mint that comes with 4.10 or even 4.12?

Otherwise, this ppa still seems valid for Ubuntu precise-based distros.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2015-08-01 01:36:28

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 858

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Mint 13 is still supported, but only until next year (vs. 2019 for Mint 17/17.1/17.2), so I would generally suggest the same unless there is some kind of technological limitation in your laptop that would mean such a step is contraindicated. Mint 13 is based on Ubuntu 12.04, so it's "less than current" in more ways than just not having a newer version of Xfce.

BtW, jimwg, something a lot - or at least a little roll - more specific than "just aren't taking" is going to be necessary in order to provide any useful troubleshooting information. Details such as exactly what you did and what results/messages you got in return, for example. Otherwise, it's like a mechanic attempting to diagnose an automobile problem solely from a report of "it just aint right," lol.

Regards,
MDM

Last edited by MountainDewManiac (2015-08-01 01:38:29)


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#4 2015-08-01 08:13:30

jimwg
Member
Registered: 2011-12-11
Posts: 67

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

ToZ wrote:

Why don't you install a newer version of Mint that comes with 4.10 or even 4.12?

Otherwise, this ppa still seems valid for Ubuntu precise-based distros.

As recommended by the Mint mavens at LinuxMint, Mint 13 Maya is the best version for early very old memory and CPU strapped machines over 15 years old like a R31. Anything beyond needs too much memory and bogs down if runs at all. There is nothing more for me to add than I ran all the XFCE and Xubuntu ppa install directions given me by other sites to the letter and the effect on changing my current XFCE version was zero. I'll check out your tips!

Jim in NYC

Last edited by jimwg (2015-08-01 08:19:02)

Offline

#5 2015-08-01 08:51:10

jimwg
Member
Registered: 2011-12-11
Posts: 67

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Failed to fetch http://ppa.launchpad.net/jblgf0/xfce-4. … ce/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/jblgf0/xfce-4. … 6/Packages  404  Not Found
Some index files failed to download. They have been ignored, or old ones used instead.

No go with ppa:jblgf0/xfce-4.10-1 it seems.

Jim in NYC

Offline

#6 2015-08-01 13:37:13

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,876

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

I just downloaded the Mint Maya 64-bit Xfce spin to have a look. It comes with Xfce 4.10 out of the box. Let me check out the 32-bit ISO.

Edit: Yes, it also comes with Xfce 4.10.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#7 2015-08-01 15:53:46

jimwg
Member
Registered: 2011-12-11
Posts: 67

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

ToZ wrote:

I just downloaded the Mint Maya 64-bit Xfce spin to have a look. It comes with Xfce 4.10 out of the box. Let me check out the 32-bit ISO.

Edit: Yes, it also comes with Xfce 4.10.

Good news, but is there any way to avoid re-doing a full iso install? Is there no standalone XFCE 4.10+ deb archive that I can install myself, especially since I've no spare CDs at hand? I'm surprised that so many sites seem closed to XFCE updating at least from 4.0.8 or Maya! Is there a way I can even "rip" XFCE off another sytem and transplant them in the right places in the R31?

Update Manager:

GPG error: http://downloads.sourceforge.net all Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CCC158AFC1289A29Failed to fetch http://packages.medibuntu.org/dists/precise/Release.gpg  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://ppa.launchpad.net/landronimirc/x … ce/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/landronimirc/x … 6/Packages  404  Not Found
Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … ce/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … 6/Packages  404  Not Found
Failed to fetch http://downloads.sourceforge.net/projec … ce/Sources  404  Not Found
Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Some index files failed to download. They have been ignored, or old ones used instead.


Just mugging thru,
Jim in NYC

Last edited by jimwg (2015-08-01 15:54:32)

Offline

#8 2015-08-01 16:33:47

grizzler
Member
From: The Hague, NL
Registered: 2014-03-15
Posts: 13

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

The medibuntu repositories have been dead for quite a while, so I would suggest removing them from your sources.list. I haven't checked the other repos that are giving 404 errors, but I assume the same goes for them.

If the current Mint Maya Xfce iso offers Xfce 4.10, I would expect an up to date repository to do the same. What does the terminal command

apt-cache policy xfce4

tell you?

Offline

#9 2015-08-01 17:24:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,876

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

jimwg wrote:

Good news, but is there any way to avoid re-doing a full iso install? Is there no standalone XFCE 4.10+ deb archive that I can install myself, especially since I've no spare CDs at hand? I'm surprised that so many sites seem closed to XFCE updating at least from 4.0.8 or Maya! Is there a way I can even "rip" XFCE off another sytem and transplant them in the right places in the R31?

That would not be an easy thing to do as it would be highly dependent on the dependencies installed and available in the host system.

.

In addition to the information provider about @grizzler about the medibuntu repositories no longer being active, you have a number of other issues with the sources in your system that are most likely interfering with upgrades:

1. "Failed to fetch http://ppa.launchpad.net/landronimirc/x … ntu/dists/maya/main/source/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/landronimirc/x … ntu/dists/maya/main/binary-i386/Packages  404  Not Found"
>>> the repository actually points to "precise" not "maya", but it is not necessary since maya already comes with Xfce 4.10

2. "Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … ce/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … 6/Packages  404  Not Found"
>>> this source no longer provides packages for precise/maya and conflicts with the source above

3. "Failed to fetch http://downloads.sourceforge.net/projec … ce/Sources  404  Not Found"
>>> this source no longer exists

4. "Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)"
>>> as mentioned by grizzler, this repository no longer exists

You need to correct these issues first. When you do so, you'll probably find that you have Xfce 4.10 installed.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#10 2015-08-01 18:36:38

jimwg
Member
Registered: 2011-12-11
Posts: 67

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Thanks to you and Grizzler and Maniac's responses! I don't want to move further unless it's reviewed by you mavens. What's my next course of action?  Just delete the repositories or relabel addresses or such? A new site?

Thanks for the help!

Jim in NYC



ToZ wrote:
jimwg wrote:

Good news, but is there any way to avoid re-doing a full iso install? Is there no standalone XFCE 4.10+ deb archive that I can install myself, especially since I've no spare CDs at hand? I'm surprised that so many sites seem closed to XFCE updating at least from 4.0.8 or Maya! Is there a way I can even "rip" XFCE off another sytem and transplant them in the right places in the R31?

That would not be an easy thing to do as it would be highly dependent on the dependencies installed and available in the host system.

.

In addition to the information provider about @grizzler about the medibuntu repositories no longer being active, you have a number of other issues with the sources in your system that are most likely interfering with upgrades:

1. "Failed to fetch http://ppa.launchpad.net/landronimirc/x … ntu/dists/maya/main/source/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/landronimirc/x … ntu/dists/maya/main/binary-i386/Packages  404  Not Found"
>>> the repository actually points to "precise" not "maya", but it is not necessary since maya already comes with Xfce 4.10

2. "Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … ce/Sources  404  Not Found
Failed to fetch http://ppa.launchpad.net/xubuntu-dev/ex … 6/Packages  404  Not Found"
>>> this source no longer provides packages for precise/maya and conflicts with the source above

3. "Failed to fetch http://downloads.sourceforge.net/projec … ce/Sources  404  Not Found"
>>> this source no longer exists

4. "Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … 6/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … tion-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Failed to fetch http://packages.medibuntu.org/dists/pre … slation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)"
>>> as mentioned by grizzler, this repository no longer exists

You need to correct these issues first. When you do so, you'll probably find that you have Xfce 4.10 installed.

Offline

#11 2015-08-01 19:24:31

grizzler
Member
From: The Hague, NL
Registered: 2014-03-15
Posts: 13

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

They're either gone or not useful. Just delete them.

Last edited by grizzler (2015-08-01 19:25:37)

Offline

#12 2015-08-01 22:55:51

jimwg
Member
Registered: 2011-12-11
Posts: 67

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

grizzler wrote:

The medibuntu repositories have been dead for quite a while, so I would suggest removing them from your sources.list. I haven't checked the other repos that are giving 404 errors, but I assume the same goes for them.

If the current Mint Maya Xfce iso offers Xfce 4.10, I would expect an up to date repository to do the same. What does the terminal command

apt-cache policy xfce4

tell you?

jwg@q ~ $ apt-cache policy xfce4
xfce4:
  Installed: 4.10.0~ppa1
  Candidate: 4.10.0~ppa1
  Version table:
*** 4.10.0~ppa1 0
        100 /var/lib/dpkg/status
     4.8.0.3 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
jwg@q ~ $

jwg@q ~ $ inxi -Sr
System:    Host: q Kernel: 3.2.0-23-generic i686 (32 bit) Desktop: Xfce 4.10.2 Distro: Linux Mint 13 Maya
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
jwg@q ~ $

Yet the desktop is still 4.0.8 by looks and features like not allowing unique wallpapers for different workspaces, etc. Maybe I'm just non-techie clueless but I'm baffled how such an issue of MIA and lost and defunct ppa sites could've gone on so long unnoticed!

Jim in NYC

Last edited by jimwg (2015-08-01 23:12:17)

Offline

#13 2015-08-01 23:40:35

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 3,876

Re: Unable To Update Mint Maya XFCE from 4.0.8 to 4.10+

Well, you have 4.10 installed.

jimwg wrote:

allowing unique wallpapers for different workspaces

This feature was introduced in 4.12.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB