Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-08-22 06:36:19

jfmxl
Member
Registered: 2015-05-21
Posts: 25

solid background in xfce desktop

The mouse is cute, but I'd prefer a solid ... maybe vertically graded ... background.

Under settings I can choose the colors for a vertical gradient ... but I see no way to deselect wallpaper of any sort.

How do you do that?

Actually the choice on the left ... mousey surrounded by graded color is OK ... but I still cannot change the color.

Or, if I'm going to have the mouse ... he/she should do something if I click ... better, hover ... over her. A somersault maybe. Or send a wave through her tail. Wink and smile, or wiggle her whiskers, at least smile

Offline

#2 2015-08-22 07:15:17

MountainDewManiac
Member
From: USA police-state welfare-state
Registered: 2013-03-24
Posts: 798

Re: solid background in xfce desktop

jfmxl wrote:

I see no way to deselect wallpaper of any sort.

jfmxl wrote:

The mouse is cute, but I'd prefer a solid ... maybe vertically graded ... background.

In that case, why not just use GIMP or another tool to create "a solid ... maybe vertically graded ... background" and select it as your desktop background?

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#3 2015-08-22 07:53:40

jfmxl
Member
Registered: 2015-05-21
Posts: 25

Re: solid background in xfce desktop

Well, yeah. But I cannot believe that there is no way to simply make what I want ... there's a way to select the colors for a graded background ... there must be a way to enable whats's been made. I'm just too thick to discover what it is ...

Speaking of my thickness ... when I first fired up xfce and clicked on the terminal emulator symbol in the bottom panel, xfce issued a complaint that no program was configured as terminal emulator. So I chose 'xterm' ... typed it in actually, there were none to chose from ... and there was no xterm program either so I still had no terminal emulator. Later I installed the xfce-terminal, very nice. And I can start it from

applcations -> system -> xfce terminal

but the panel buttons for terminal emulator are stuck on the none existent xterm and I cannot change them.

Actually, I was able to add xfce terminal to the bottom panel as an application launcher, and then delete the old, broken terminal emulator. But I see no way to trick the Applications menu the same way. I seem to have a permanently dysfunctional icon in the Applications menu.

Again, actually, looking a little more closely, I see that I can substitute a custom Applications menu file for the default. If I knew where the default menu file was, I could copy it to a new, custom location. Then I could edit the custom menu file to call xfce-terminal as terminal emulator and substitute my custom file for the default and see if it worked. If it did, I could move it back to default.

But maybe there's an easier way.

Offline

#4 2015-08-22 13:15:09

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,591

Re: solid background in xfce desktop

As MDM says, the desktop applet is only for selecting images, not manipulating them or creating gradients. He is right in that you'll have to create what you want in an image editor and then select that as your background.

As for the broken icon, the icon actually runs "exo-open --launch TerminalEmulator" and for that to resolve to something, you need to set a value for "TerminalEmulator". You can do this via Settings Manager >> Preferred Applications >> Utilities Tab >> Terminal Emulator, and select the terminal editor you want to use. In fact, while you are there, set all 4 of the preferred settings so all of the other icons will work.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#5 2015-08-22 22:03:47

jfmxl
Member
Registered: 2015-05-21
Posts: 25

Re: solid background in xfce desktop

Wow. I just had a look at the xfce 4.10 desktop here on this debian machine and sure enough, no-image, vertical gradient is an option. I guess that the ability to set a gradient in 4.12 is a relict, an appendix, that no longer has any real function? No problem. I can live with the mousey and blue-green background.

The fix for my icon problem worked like a charm. I feel pretty dopey not discovering that for myself. I'll have to wait til I can figure out how to get firefox/iceweasel and thunderbird/icedove to compile on gentoo to set them as preferred applications on my 'new' machine ... maybe I'll have to switch to midori/claws I wish there were an O'Reilly book on Portage. There's one on gentoo ... about 15 years old ... but I'm afraid that might misinform me at this point.

Thanks for all your help.

Offline

#6 2017-02-19 01:46:17

Owen Everbinde
Member
Registered: 2017-02-19
Posts: 1

Re: solid background in xfce desktop

In the "style" dialog -- the one with tiled, zoom, etc -- there an option for "none". Check that, and you will land on your solid or gradient background color. About the least intuitive place one could look for it.

I know this is a bit late, but I just couldn't help posting here, because I stumbled onto it accidentally and had to tell somebody. I did NOT expect that! Anyways, in case you're still interested in a gradient desktop, that's how.

Last edited by Owen Everbinde (2017-02-19 01:48:23)

Offline

Board footer

Powered by FluxBB