Xfce Forum

Sub domains
 

You are not logged in.

#1 2006-08-31 12:18:33

m3talgod
Member
Registered: 2006-08-31
Posts: 4

[solved] Battery-Monitor applet doesn't work anymore in new Beta2

Hi @ all,

just installed the new Beta2 using the graphical installer. I'm using Xubuntu 6.06.
If I try to add the battery-monitor to the panel, it disappears immediately if I close
the configuration window that appears after the applet is added.

Any suggestions???  :?

Offline

#2 2006-08-31 17:04:33

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

Offline

#3 2006-09-01 07:15:47

m3talgod
Member
Registered: 2006-08-31
Posts: 4

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

Thanks for the fast reply smile. I tried the version from the snapshot you mentioned , but
with no success  :-(. The applet still disappears after closing the configuration dialog.
I checked the optimization option in the installer so I guess I have no debug support?
Otherwise I'd try to follow this suggestion:
http://www.nabble.com/Battery-Monitor-p … 23376.html

Any other suggestions?  :?

Offline

#4 2006-09-01 09:11:23

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

I've fixed the bug and fixing some other problems atm. I'll release a
beta version when I'm done.

Nick

Offline

#5 2006-09-01 11:18:23

m3talgod
Member
Registered: 2006-08-31
Posts: 4

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

That's great news! Looking forward...  smile

Offline

#6 2006-09-01 12:33:25

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

A new version (0.4.90.2) will be released within 8 hours from now. An announcement
will be posted on the mailinglists and the tarball will be droped
here: http://goodies.xfce.org/releases/

Changelog:
    * panel-plugin/battmon.c, panel-plugin/libacpi.c: Applied patches (or
    parts of it) from Bug #1261, Bug #1475
    * panel-plugin/battmon.c, panel-plugin/libacpi.c: NetBSD patch from
    Stefan Sperling
    * configure.ac, autogen.sh, po/LINGUAS: Switch to linguas support,
    rename configure.in to configure.in.in
    * po/xfce4-battery-plugin.pot: Addded file
    * po/*.po: Regenerated po files
    * panel-plugin/libacpi.c: Apply patch from Giuseppe Ciotta to
    remove hardcoded battery paths.
    * panel-plugin/battmon.c: Fix crash when adding the plugin.
    * panel-plugin/battmon.c: Fix plugin resize problem (bug #1791)
    * panel-plugin/battmon.c: Improved icon loading and try to load the
    battery icon from your current theme (fallback on buildin icon).
    * panel-plugin/battmon.c: Initially hide the icon when building the
    plugin (this stops the icon from flashing if disabled).
    * panel-plugin/battmon.c: Remove the time label from "display percentage"
    and add a new option "Display time".
    * panel-plugin/battmon.c: Fix label alignment if only 1 "option" is shown
    in a vbox.
    * panel-plugin/battmon.c, configure.ac: Use new titled dialog and depend on
    beta 2.
    * panel-plugin/battmon.c: Couple of small fixes, improvement, memleaks etc.

Offline

#7 2006-09-04 07:51:49

m3talgod
Member
Registered: 2006-08-31
Posts: 4

Re: [solved] Battery-Monitor applet doesn't work anymore in new Beta2

Just installed the 0.4.90.2 version on the new 4.4RC1 system and it works great - thanks a lot!!!  smile

Offline

Board footer

Powered by FluxBB