Xfce Forum

Sub domains
 

You are not logged in.

#1 2006-11-04 02:37:44

satimis
Member
Registered: 2006-11-04
Posts: 30

How to read Chinese

Hi folks,

I have been looking around for advice to solve my problem as follow;

Ubuntu-6.06.1-server-amd64
xfce4

This is a server for TEST only without X.  Because I need googling to help me in case of problem on configuration.  Then I installed xfce4 and Firefox.  On xfce4 desktop menu there are certain items not availble because I did not install the full core of window-system.  Now my problem is on browsing I can't read Chinese.

$ locale | grep LANG=

LANG=en_US.UTF-8

no zh_TW/zh_TW.UTF-8/zh_CN/zh_CN.UTF-8 etc. displayed.


$ sudo dpkg-reconfigure locales

Password:
Generating locales...
  en_US.UTF-8... up-to-date
  zh_CN.UTF-8... up-to-date
  zh_HK.UTF-8... up-to-date
  zh_SG.UTF-8... up-to-date
  zh_TW.UTF-8... up-to-date
Generation complete.
Running 'tzconfig' to set this system's timezone.
Your current time zone is set to 
Do you want to change that? [n]: no
Your time zone will not be changed

They are there.  Please advise how to solve my problem.  TIA


B.R.
satimis

Offline

#2 2006-11-04 14:42:05

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: How to read Chinese

The locales you've generated are the glibc languages, all xfce translations are included in the packages:

run:

export LANG=zh_TW
export LC_ALL=zh_TW

and then start xfce (startxfce4)

Offline

#3 2006-11-05 12:00:56

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Nick,

Tks for your advice.  performed following tests.

1)
As user
$ export LANG=zh_TW
$ export LC_ALL=zh_TW
(both without complaint)

$ startxfce4
started X

then started Firefox
View --> Character Encoding --> Traditional Chinese (Big5)
Stitt can't read Traditional Chinese


2)
As user
$ export LANG=zh_TW.UTF-8
$ export LC_ALL=zh_TW.UTF-8
(both without complaint)

$ startxfce4
started X

then started Firefox
View --> Character Encoding --> Traditional Chinese (Big5)/Unicode (UTF-8)
Stitt can't read Traditional Chinese


3)
As user
$ export LANG=zh_CN
$ export LC_ALL=zh_CN
(both without complaint)

$ startxfce4
started X

then started Firefox
View --> Character Encoding --> Simplified Chinese (GBK)
Stitt can't read  Simplified Chinese


4)
As user
$ export LANG=zh_CN.UTF-8
$ export LC_ALL=zh_CN.UTF-8
(both without complaint)

$ startxfce4
started X

then started Firefox
View --> Character Encoding --> Simplified Chinese (GBK)/Unicode (UTF-8)
Stitt can't read  Simplified Chinese


B.R.
satimis

Offline

#4 2006-11-06 08:29:26

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

Hi satimis,

Did you install a Chinese font such as ttf-arphic-uming or bitstream-cyberbit?
These two fonts are able to show both simplified and traditional Chinese.
Also don't forget to choose the right character encoding such as UTF-8, GB2312 (GBK) or Big5 depending on the text you want to read.
I am using Debian, xfce4 and firefox, locale en_US.UTF-8 and don't have any problem reading Chinese (and writing with scim).

b.r.,
Jos

Offline

#5 2006-11-06 12:11:24

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

Tks for your advice.

Did you install a Chinese font such as ttf-arphic-uming or bitstream-cyberbit?
These two fonts are able to show both simplified and traditional Chinese.

No.

$ sudo apt-cache search ttf-arphic-uming

ttf-arphic-uming - "AR PL ShanHeiSun Uni" Chinese Unicode TrueType font Mingti style

$ sudo apt-get install ttf-arphic-uming

Reading package lists... Done
Building dependency tree... Done
Suggested packages:
  x-ttcidfont-conf xdelta
The following NEW packages will be installed:
  ttf-arphic-uming
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 12.5MB of archives.
After unpacking 21.8MB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com dapper/main ttf-arphic-uming 0.1
12.5MB]
Fetched 12.5MB in 3m31s (59.2kB/s)
Preconfiguring packages ...
Selecting previously deselected package ttf-arphic-uming.
(Reading database ... 32264 files and directories currently install
Unpacking ttf-arphic-uming (from .../ttf-arphic-uming_0.1.20060513-
.
Setting up ttf-arphic-uming (0.1.20060513-1) ...

Now Firefox can display both Traditional and simplified Chinese.  Tks.

What packages shall I install for editing Traditional Chinese?  I'm only familiar with "Easy/Cangji" input methods?  TIA.

Furthermore which package provides "equery"?

$ sudo apt-cache search equery

xfe - lightweight file manager for X11

$ sudo apt-get install xfe

Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  libfox1.4
Recommended packages:
  rpm
The following NEW packages will be installed:
  libfox1.4 xfe
0 upgraded, 2 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 1771kB of archives.
After unpacking 5968kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://us.archive.ubuntu.com dapper/universe libfox1.4
1.4.16-2ubuntu3 [954kB]
Get:2 http://us.archive.ubuntu.com dapper/universe xfe 0.84-4 [816kB]
Fetched 1771kB in 31s (56.0kB/s)
Selecting previously deselected package libfox1.4.
(Reading database ... 32297 files and directories currently installed.)
Unpacking libfox1.4 (from .../libfox1.4_1.4.16-2ubuntu3_amd64.deb) ...
Selecting previously deselected package xfe.
Unpacking xfe (from .../archives/xfe_0.84-4_amd64.deb) ...

Setting up libfox1.4 (1.4.16-2ubuntu3) ...

Setting up xfe (0.84-4) ...

$ man equery
No manual entry for equery
$ which equery
No printout


Others noted with tks.


B.R.
satimis

Offline

#6 2006-11-06 13:27:24

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

[ What packages shall I install for editing Traditional Chinese?  I'm only familiar with "Easy/Cangji" input methods?  TIA./quote]

I'm only familiar with pinyin input method and simplified Chinese using SCIM.
I think you could use the scim package with the additional package scim-tables-zh which provides CangJie.

SCIM (Smart Common Input Method) is an input method (IM) platform.
Package: scim-tables-zh
This package contains SCIM table-based input method data for Chinese. Currently the provided tables are:
Array30, CangJie, CangJie3, CangJie5, Cantonese, CantonHK, CNS11643, Dayi3, EZ-Big, Erbi, Erbi-QS, Jyutping, Quick, Simplex, Stroke5, Wubi, Wu, ZhuYin, ZhuYin-Big, and Ziranma.

You should add:
---
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &
---
to your /etc/gdm/Xsession!

Offline

#7 2006-11-08 02:40:00

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

Tks for your further advice.

You should add:
---
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &
---
to your /etc/gdm/Xsession!

Since this box is a server.  I don't expect having too many X packages installed.

I don't need "Chinese editing" function started at boot.  I expect start it manually in need.

"scim" and "gdm" are not installed.  I'll install "scim".  Can I leave "gdm"?  If each time I need "Chinese editing" I'll start it manually after starting Xfce4

TIA

B.R.
satimis

Offline

#8 2006-11-09 13:36:30

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

Did you already try Scim?
If you have some problem, just ask!

Offline

#9 2006-11-09 15:01:46

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

Did you already try Scim?

$ sudo apt-get install scim

Installation went through without complaint.

$ sudo apt-cache policy gdm

gdm:
  Installed: (none)
  Candidate: 2.14.10-0ubuntu1
  Version table:
     2.14.10-0ubuntu1 0
        500 http://us.archive.ubuntu.com dapper-updates/main Packages
     2.14.6-0ubuntu2.1 0
        500 http://security.ubuntu.com dapper-security/main Packages
     2.14.6-0ubuntu2 0
        500 http://us.archive.ubuntu.com dapper/main Packages

gdm not installed.

$ export XMODIFIERS="@im=SCIM"
$ export GTK_IM_MODULE="scim"
$ exec scim -d &

[1] 5086
satimis@ubuntu:~$ Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM as daemon ...
SCIM has been successfully launched.

$ editor test.txt
started a blank document.

[shift], [Ctrl], {Space], etc. no toggle function to start Chinese editing.


B.R.
satimis

Offline

#10 2006-11-09 15:35:22

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

你好!

SCIM has been successfully launched.

that's OK!

[shift], [Ctrl], {Space], etc. no toggle function to start Chinese editing

ctrl-space: a short toolbar (scim) should appear on the right side of your screen.
ctrl-shift: choose the input method (English, Chinese Simplified, Traditional, etc).
right click on that tool bar, you see Scim Set Up,
Open an editor, choose the input method: Scim.

That's the way it works, all this in the same terminal of course.

Offline

#11 2006-11-10 02:21:33

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

To get rid of your problems, please do exactly what I tell you!

The Chinese input doesn't work with all terminals (or console, that's the same).
First of all did you install the xfce4-terminal correctly? It should be your default terminal.
Then you can adjust the font as I already mentioned.

You should have installed scim, scim-gtk2-immodules, scim-modules-socket, scim-tables-zh,
to test your input method also install scim-pinyin (only for test, if it works, you can use changjie)

Then run your console (xfce4-terminal),
Type:
$ export XMODIFIERS="@im=SCIM"
$ export GTK_IM_MODULE="scim"
$ exec scim -d &

Now scim runs as a daemon in the background!
Open an editor (mousepad, gedit or nano - I tested scim also works wth nano) in that same terminal (console),
cntrl-space
scim input should now show up, maybe you need to check the scim setup.
with cntrl-shift choose chinese input (中),
try typing nihao in the input window (lookup table), you should see 你好 (under number 1), press 1 and the Chinese characters appear
in your editor.

Offline

#12 2006-11-10 02:28:06

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos

你好!

ctrl-space: a short toolbar (scim) should appear on the right side of your screen.
ctrl-shift: choose the input method (English, Chinese Simplified, Traditional, etc).

I tried several times, no short toolbar found.  Editor started with a blank document.

Besides after exiting SCIM on pressing [Ctrl]+c

[1]+  Done                    exec scim -d

I can't start it again.

$ export XMODIFIERS="@im=SCIM"
$ export GTK_IM_MODULE="scim"
$ exec scim -d &

[1] 4898
Smart Common Input Method 1.4.4

satimis@ubuntu:~$ Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to launch SCIM.

I must reboot the PC before I can start SCIM.


B.R.
satimis

Offline

#13 2006-11-10 02:51:03

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

ubuntu-6.06.1-LAMP-server-amd64

First of all did you install the xfce4-terminal correctly? It should be your default terminal.

There is only one terminal, Xfce4, on this server.


You should have installed scim, scim-gtk2-immodules, scim-modules-socket, scim-tables-zh,
to test your input method also install scim-pinyin (only for test, if it works, you can use changjie)

$ sudo apt-cache policy scim

scim:
  Installed: 1.4.4-1ubuntu12
  Candidate: 1.4.4-1ubuntu12
  Version table:
 *** 1.4.4-1ubuntu12 0
        500 http://us.archive.ubuntu.com dapper/main Packages
        100 /var/lib/dpkg/status

installed already.

$ sudo apt-cache policy scim-gtk2-immodules

W: Unable to locate package scim-gtk2-immodules

Not installed yet.

$ sudo apt-cache policy scim-modules-socket

scim-modules-socket:
  Installed: 1.4.4-1ubuntu12
  Candidate: 1.4.4-1ubuntu12
  Version table:
 *** 1.4.4-1ubuntu12 0
        500 http://us.archive.ubuntu.com dapper/main Packages
        100 /var/lib/dpkg/status

installed already.

$ sudo apt-cache policy scim-tables-zh

scim-tables-zh:
  Installed: (none)
  Candidate: 0.5.6-1build1
  Version table:
     0.5.6-1build1 0
        500 http://us.archive.ubuntu.com dapper/main Packages

not yet installed.

$ sudo apt-get install scim-gtk2-immodules

Password:
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package scim-gtk2-immodules

This package can't be found on repositories.  Where can I get it?  Tks

$ sudo apt-get install scim-tables-zh

Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  scim-modules-table
The following NEW packages will be installed:
  scim-modules-table scim-tables-zh
.....
Unpacking scim-tables-zh (from .../scim-tables-zh_0.5.6-1build1_all.deb) ...

installation went through without complaint.

Tks.


B.R.
satimis

Offline

#14 2006-11-10 07:18:58

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

There is only one terminal, Xfce4, on this server.

Did you install the package xfce4-terminal, the xfce terminal emulator?
Check this, check your xfce settings manager, preferred applications, utilities, terminal emulator,
this latter should be set to xfce4-terminal.

This package can't be found on repositories.  Where can I get it?

Sorry, the package name is scim-gtk2-immodule, not immodules.

Install what I told you and try again, doing exactly as I said.
If everything is  correctly installed, then at pressing ctrl-space, the scim tool bar should  appear.
On my notebook it works without problems.

Offline

#15 2006-11-10 14:57:19

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

the package name is scim-gtk2-immodule, not immodules.

$ sudo apt-cache policy scim-gtk2-immodule

Password:
scim-gtk2-immodule:
  Installed: 1.4.4-1ubuntu12
  Candidate: 1.4.4-1ubuntu12
  Version table:
 *** 1.4.4-1ubuntu12 0
        500 http://us.archive.ubuntu.com dapper/main Packages
        100 /var/lib/dpkg/status

Already installed.

Now I can edit Chinese on Xfce4-terminal.  How to get Chinese editing to work on browser?  TIA.

Others noted with tks.

B.R.
satimis

Offline

#16 2006-11-10 15:09:22

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

Do you have the right font size now?
Did you try Chinese input in an editor, maybe nano, and does it work?

How to get Chinese editing to work on browser?

Which browser are you using? I am using Firefox.
Try starting your browser in the terminal.

As I previously mentioned, if you put
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &
in your Xsession, starting before XFCE4, your Chinese Input will always be ready and available for all apps that are aware of Scim.

Offline

#17 2006-11-10 16:10:44

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Jos wrote:

Do you have the right font size now?

Yes.

Did you try Chinese input in an editor, maybe nano, and does it work?

Yes, I did it on xfce4-terminal.  It worked seamlessly.  Just right-click --> select "Input Methods" --> "SCIM Input Method"
Then it worked without running;
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &

Which browser are you using?

Firefox.

On xfce4-terminal ran;
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &

[1] 5803
satimis@ubuntu:~$ Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM as daemon ...
SCIM has been successfully launched.

Started another xfce4-terminal and on it started firefox.

Ctrl+Space has no function.  Can't edit Chinese.

As I previously mentioned, if you put
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
exec scim -d &
in your Xsession, starting before XFCE4, your Chinese Input will always be ready and available for all apps that are aware of Scim.

Noted with tks.  Because this PC is server, I expect to start them manually when I need editing Chinese.

B.R.
satimis

Offline

#18 2006-11-11 03:45:20

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

Congratulations, most problems are now solved!

Yes, I did it on xfce4-terminal.

Do also try in an editor such as nano, mousepad, gedit.
With some editors Chinese input doesn't work !

Started another xfce4-terminal and on it started firefox.
Ctrl+Space has no function.  Can't edit Chinese.

Try starting Firefox in the same terminal as Scim.  First test if you have Chinese input in the terminal,
then try the Chinese input in an input window of Firefox.
It should also work with Thunderbird.

If you don't get Scim input on Firefox (or Thunderbird) then you have to start your Scim as a daemon before you start XFCE4
as I explained previously.

PS. You really don't need:
$ export LANG=zh_TW.UTF-8
$ export LC_ALL=zh_TW.UTF-8

Using LANG=en_US.UTF8 or another language is OK as long as it is UTF-8!

Offline

#19 2006-11-11 06:35:31

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

Congratulations, most problems are now solved!

Lot of tks for your assistance in advising me continueously.

Do also try in an editor such as nano, mousepad, gedit.
With some editors Chinese input doesn't work !

On xfce4-terminal only.

Try starting Firefox in the same terminal as Scim.  First test if you have Chinese input in the terminal,
then try the Chinese input in an input window of Firefox.
It should also work with Thunderbird.

1) started a new xfce-terminal.  Chinese editing worked perfectly on it

2) on the same xfce-terminal, started "firefox"
--> yahoo webmail --> compose
Pressing [Ctrl]+[Space-bar] has no effect.  Failed to toggle betwen English and Chinese.

3) on the same xfce-terminal ran;
$ export XMODIFIERS="@im=SCIM"
$ export GTK_IM_MODULE="scim"
$ exec scim -d &

[1] 4983
satimis@ubuntu:~$ Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM as daemon ...
SCIM has been successfully launched.
(mouse pointer hanging here)

Still having no toggling function.

PS. You really don't need:
$ export LANG=zh_TW.UTF-8
$ export LC_ALL=zh_TW.UTF-8
Using LANG=en_US.UTF8 or another language is OK as long as it is UTF-8!

I did not run the above commands.


B.R.
satimis

Offline

#20 2006-11-11 07:55:45

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

On xfce4-terminal only.

Please first try if it works with an editor before you try Firefox!

Offline

#21 2006-11-11 10:23:50

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Jos wrote:

On xfce4-terminal only.

Please first try if it works with an editor before you try Firefox!

1)
Started xfce4-terminal
Right-click --> Input Methods --> SCIM Input Method

2)
On xfce4-termina ran;
$ editor

to start 'editor'  Chinese editing worked without problem.

3)
Closed the editor.  On same xfce4-termina ran;
$ firefox

to start 'firefox'.  Toggling did not work.  Chinese editing failed.


Tks.


B.R.
satimis

Offline

#22 2006-11-11 10:57:52

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

Hi,
I killed my Scim and start again the way you do.

to start 'editor'  Chinese editing worked without problem.

OK, this works as it should, I did the same!

[to start 'firefox'.  Toggling did not work.  Chinese editing failed./quote]

Then I tried the following which you too should try:
------
jos@5-33-ftth:~$ export XMODIFIERS="@im=SCIM"
jos@5-33-ftth:~$ export GTK_IM_MODULE="scim"
jos@5-33-ftth:~$ scim -d&
[1] 6996
jos@5-33-ftth:~$ Smart Common Input Method 1.4.4

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM as daemon ...
SCIM has been successfully launched.

[1]+  Done                    scim -d
jos@5-33-ftth:~$ firefox

-------
你好! as you can see it works.
Now try exactly the same, it should work, I guess (?!)
PS. To go back to your terminal after "SCIM has been successfully launched." just press Enter!

Offline

#23 2006-11-11 11:24:06

Jos
Member
Registered: 2006-11-06
Posts: 21

Re: How to read Chinese

On my Debian notebook it's even simpler to get Chinese input in Firefox.
As you can see Firefox (running in the xfce4-terminal) seems to launch Scim ....

------
jos@5-33-ftth:~$ export GTK_IM_MODULE="scim"
jos@5-33-ftth:~$ firefox
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
GTK Panel of SCIM 1.4.4

--------
中文。。。

Offline

#24 2006-11-11 12:26:06

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi Jos,

On my Debian notebook it's even simpler to get Chinese input in Firefox.
As you can see Firefox (running in the xfce4-terminal) seems to launch Scim ....

Still can't figure out the cause of unable editing Chinese on browser.  I think maybe there are some packages not installed because this is a server.

In case necessitating editing Chinese on browser I will edit the document on xfce4-terminal first and copy the finished text on the browser thereafter.

Anyway thanks again for your time and effort in assisting me.


B.R.
satimis

Offline

#25 2007-02-16 14:44:39

satimis
Member
Registered: 2006-11-04
Posts: 30

Re: How to read Chinese

Hi jos and folks,

slamd64-11.0
xfce4

Chinese editing and reading again.

I'm now running the captioned OS.  Neither can I read nor input Chinese.

I can't find ttf-arphic-uming on mirror to download.

# slackpkg search ttf-arphic-uming

No package contains the selected pattern.

Googling brought me to following English link:
http://software.opensuse.org/download/h … 8-3.1.html

Can this package be used?

I found some others but all in Chinese which I can't read its content.  Please help.  TIA


B.R.
satimis

Offline

Board footer

Powered by FluxBB