Xfce Forum

Sub domains
 

You are not logged in.

#1 2006-12-19 18:34:10

gio27
Member
Registered: 2006-12-19
Posts: 3

Problem making exo...

Hi everybody!  smile
I'm having a problem using the graphical installer on Xubuntu (I want to update XFCE).
When it makes Extension Library it says me

Running configure... done
Running make all... failed

The error log says:

cc1: warnings being treated as errors
exo-icon-view.c: In function 'exo_icon_view_layout_cols':
exo-icon-view.c:3188: warning: 'rows' may be used uninitialized in this function
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DDATADIR=\"/root/local/XFCE/share\" -DEXO_API_SUBJECT_TO_CHANGE -DEXO_COMPILATION -DG_LOG_DOMAIN=\"exo\" -DLIBEXECDIR=\"/root/local/XFCE/libexec\" -DLIBEXO_VERSION_API=\"0.3\" -DPACKAGE_LOCALE_DIR=\"/root/local/XFCE/share/locale\" -I/root/local/XFCE/include -I/usr/include -DHAVE_GNUC_VISIBILITY -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/root/local/XFCE/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/root/local/XFCE/include -I/usr/include -O2 -pipe -Wall -Werror -MT libexo_0_3_la-exo-md5.lo -MD -MP -MF .deps/libexo_0_3_la-exo-md5.Tpo -c exo-md5.c -o libexo_0_3_la-exo-md5.o >/dev/null 2>&1
make[3]: *** [libexo_0_3_la-exo-icon-view.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/tmp/xfce4-4.4RC2-installer/exo/exo'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/xfce4-4.4RC2-installer/exo/exo'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/xfce4-4.4RC2-installer/exo'
make: *** [all] Error 2
!! Failed to build exo, see the errors above
!! for details on the problem.

I've installed libperl5.8 and libxml-perl, but nothing changes.
What can I do?

Thank's

Offline

#2 2006-12-19 18:46:25

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Problem making exo...

You probably compiling with debug fully enabled. Remove -Werror from the CFLAGS.

Offline

#3 2006-12-19 18:54:41

gio27
Member
Registered: 2006-12-19
Posts: 3

Re: Problem making exo...

Thank you. How can I do that? I have used linux for a year but I never had a problem like this. :-|
Than you very much for your help    lol

Offline

#4 2006-12-20 10:17:55

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Problem making exo...

Set compile flags before running the installer. Replace i686 with your cpu type, checkout gcc manual. Also make sure 'Extensive Optimizations' is enabled in the installer.

#export CFLAGS="-march=i686 -O2 -pipe"

This way the installer won't use some debugging flags AFAIK.

Offline

#5 2006-12-20 14:02:42

gio27
Member
Registered: 2006-12-19
Posts: 3

Re: Problem making exo...

Thank's. It went all well exept a problem with ALSA that I resolved looking at a topic in this forum.
Now I'll configure gdm.  smile

Thank you

Offline

Board footer

Powered by FluxBB