Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-01-22 15:05:36

lgeneste
Member
Registered: 2007-01-22
Posts: 2

[Solved] Problem installing xfce 4.4.0

First of all, I wish to thank the members of the xfce team for making such a nice and powerful desktop environment. I have been using it for monthes and would not change easily now !

I am trying to install the version 4.4.0 but I am facing a problem when compiling "libexo". I have the following error messages :

exo-hal.c: In function 'exo_hal_drive_compute_display_name':
exo-hal.c:392: error: 'LIBHAL_DRIVE_CDROM_CAPS_HDDVDRW' undeclared (first use in this function)
exo-hal.c:392: error: (Each undeclared identifier is reported only once
exo-hal.c:392: error: for each function it appears in.)
exo-hal.c:394: error: 'LIBHAL_DRIVE_CDROM_CAPS_HDDVDR' undeclared (first use in this function)
...

I am using Suse Linux 10.1. I checked some dependancies : dbus is version 0.60-30, hal is version 0.5.6-33.11, udev is version 085-30.16.

Thanks for your help

Laurent

Offline

#2 2007-01-22 15:11:01

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [Solved] Problem installing xfce 4.4.0

Well your hal version if a bit old, you can try updating to the latest version 0.5.8. Maybe you also need the -devel package of hal.

Offline

#3 2007-01-22 16:28:53

lgeneste
Member
Registered: 2007-01-22
Posts: 2

Re: [Solved] Problem installing xfce 4.4.0

Thanks for this fast & appropriate answer. I upgrade to hal 0.5.8 (using opensuse 10.2 repositories) and everything was OK.

Offline

Board footer

Powered by FluxBB