Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-01-24 12:17:13

Ragnar Roeck
Member
Registered: 2007-01-24
Posts: 3

Slows to a crawl for seconds, then back to normal (solved)

1. I have to get this solved, because xfce is exactly what I want after working with it for even a couple of hours.

In a couple of programs (e.g. Opera, Gimp, Thunar) I notice a random slowdown. I can't move anything but the mousepointer for a couple of seconds, the windows get updated that slow, you can see the single lines been drawn. The clock stands still, then keeps up. I can normally force it to happen if I grab a window and "draw" circles with it.

I used ubuntu and then installed xfce from synaptic. Also upgraded to 4.4.0 with the graphical installer. No change. Processor is A64/3500 with 1.5Gig Ram. I use "on-demand" powersavings under gnome, but even if that's the culprit - the 1GHz should be enough to render, right?

Offline

#2 2007-01-24 13:34:29

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Slows to a crawl for seconds, then back to normal (solved)

Do you also have this problem without the compositor? And then you run top in a terminal (sorted by cpu usage), are there any applications jumping to a heavy cpu load?

Offline

#3 2007-01-24 16:19:03

Ragnar Roeck
Member
Registered: 2007-01-24
Posts: 3

Re: Slows to a crawl for seconds, then back to normal (solved)

The compositor wasn't switched on. I tried, but it makes no difference.

The terminalwindow with top freezes like all the others, but when it starts updating again, Xorg is nearly on 100%.

at this site: http://turkey.fvdh.net/~hanumizzle/xfce4-review/

I found:

"The Xfce compositor is not as flexible as the standalone xcompmgr, but is apparently more stable and easier to configure. I found out something very strange in experimenting with the Xfce compositor: it ran significantly faster under the generic VESA driver rather than under the the driver written specifically for my Via Unichrome card; completely counterintuitive, but what a shot in the dark! (lxdoom ran consistently faster as well; good news for lxdoom, bad news for productivity.) If you experience slowness with the compositor, you may wish to consider trying this as well."

I might try vesa, since I don't use the 3D part of my GF6800 under Linux so far anyway.

If you or someone has an idea based on the Xorg process I'd be happy to follow your instructions.

Offline

#4 2007-01-24 17:56:11

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Slows to a crawl for seconds, then back to normal (solved)

Well if you have a nvidia card, you should try the nvidia driver with RenderAccel and AllowGLXWithComposite enabled. It's not this driver is better with opengl applications, but it also improved the (x)render speed of Xorg.

Offline

#5 2007-01-24 20:34:18

Ragnar Roeck
Member
Registered: 2007-01-24
Posts: 3

Re: Slows to a crawl for seconds, then back to normal (solved)

You pointed me at the right direction! I had a session autostart for core and mem speed of my graphicscard under gnome. It was deselected, but Xfce somehow takes the setting anyway. It is an underclocking (87Mhz core 400MHz mem) and it would choke under gnome, too. Totally forgot that I had it sitting there. Thanks for your help!

Offline

Board footer

Powered by FluxBB