Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-01-23 05:40:35

garybrlow
Member
Registered: 2006-11-15
Posts: 6

[SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

I can't get past the System Requirements/Mandatory Dependencies screen due to dependency issues. I have all the required libraries installed except that the installer does not recognize some library versions higher than what is requires. Particularly with the following libraries:

Library                       Installer Ver.      Xubuntu Ver.

libxml                          2.4.0                2.6.26
vte                             0.11.1              0.14.1
libstartup-notification     0.4                  0.8
hal-storage                  0.5.                 0.5.7
dbus-glib                      0.34                0.71     

Any suggestions and recommendations to go around this problem is most welcome.

Thanks in advance.

Cheers!

GaryBrlow smile


Linux User #435593 | Xubuntu User #9638

Offline

#2 2007-01-23 07:32:16

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

Make sure you have the devel packages or the missing deps installated.

Offline

#3 2007-01-23 14:50:05

garybrlow
Member
Registered: 2006-11-15
Posts: 6

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

Agrh! Silly me, I actually thought I installed all the dev libraries but apparently I didn't. It works now. Thank you Nick.

Cheers!

GaryBrlow tongue


Linux User #435593 | Xubuntu User #9638

Offline

#4 2007-01-27 08:00:01

netkhark
Member
Registered: 2007-01-27
Posts: 1

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

I installed couple libraries :
- libgtk2.0-dev
- libice-dev
- libsm-dev
- libxpm-dev
as instructed on http://www.xfce.org/documentation/installers/xfce/
and i have my edgy updated to latest : apt-get update, apt-get upgrade

but, I still failed on packages vte, hal-storage, dbus-glib-1 and library jpeg

GaryBrlow, what are the dev libraries that you installed to make the installation work.

Thanks!

Offline

#5 2007-01-28 01:47:21

garybrlow
Member
Registered: 2006-11-15
Posts: 6

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

Netkhark,

(X)Ubuntu updated their XFCE packages to 4.4.0 (its still a bit cranky though, thunar causes access slowdowns and 100% cpu in most cases and am still observing it). Be sure to update your packages first for the latest versions. Use Synaptic to get the dev packages for example search for "vte dev" or "hal-storage dev" etc. and it will find the file for you, select and mark it for installation. Typing only the package name doesn't necessarily bring up the dev packages. After marking all the needed libraries, click apply, then wait for it to finish. XFCE 4.4.0 only needs what it requires via the GUI installer which virtually covers everything unlike the earlier Release Candidates that have dependencies not covered in the checklist. I could be wrong though but  I didn't need to install anything else other than what the GUI installer required. smile

Cheers!!!

GaryBrlow  ;D


Linux User #435593 | Xubuntu User #9638

Offline

#6 2007-01-28 14:24:50

wlkngowl
Member
From: Between Heaven and Earth
Registered: 2005-11-11
Posts: 77

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

garybrlow wrote:

(X)Ubuntu updated their XFCE packages to 4.4.0 ...

I have Xubuntu Edgy, and the packages have not yet been updated to 4.4.0.  Maybe for the Feisty release?

Offline

#7 2007-01-28 18:37:56

garybrlow
Member
Registered: 2006-11-15
Posts: 6

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

Unfortunately am testing feisty as of the moment, I guess the update is only for feisty then. They should be backporting it as soon as package bugs eliminated/minimized and are good to go. But for the meantime, use the official installer to update XFCE and Thunar to current version. I suggest using the Thunar Bundle so as no to compile plugins individually. I have had no problems using the official stable installers to date. One thing I like about it is that the official one restates the original menu that xubuntu removed and replaced with their own. Even if you uninstall the gui installer the menus are retained.  smile

Cheers!!!

GaryBrlow  ;D


Linux User #435593 | Xubuntu User #9638

Offline

#8 2007-01-29 23:12:23

Glanz
Member
From: Thule
Registered: 2004-05-19
Posts: 3
Website

Re: [SOLVED]Unable to install XFCE 4.4.0 on Xubuntu Edgy using graphic installer

Many of the little glitches and annoyances in Feisty XFCE 4.4.0 mentioned earlier have been corrected by incremental upgrades today.

Offline

Board footer

Powered by FluxBB