Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-06 17:12:33

brad
Member
Registered: 2007-02-06
Posts: 9

Menu entry not working

Is there something tricky or buggy about the menu layout editor? I added an entry (korganizer) under a section (Office) and it never showed up (yes "Show" is clicked).

In fact, there was already another entry there that never showed up either. Neither of these entries have icons assigned. Interestingly, the entry right below the one that does not appear does not have it's icon showing - but it it should since it is assigned in the menu layout editor. Maybe that's a clue.

Also, if I move the entries around it makes no difference in the desktop menu.

thanks,
brad

Offline

#2 2007-02-06 19:44:52

wlkngowl
Member
From: Between Heaven and Earth
Registered: 2005-11-11
Posts: 77

Re: Menu entry not working

brad wrote:

Is there something tricky or buggy about the menu layout editor? I added an entry (korganizer) under a section (Office) and it never showed up (yes "Show" is clicked).

I'm not sure where those menu items come from. There are things in that applet that aren't in my menu, and things in my menu (the category "Science"), that aren't in that applet.

I just edit or add *.desktop entries in /usr/share/applications or /usr/local/share/applications.

Offline

#3 2007-02-07 16:14:39

brad
Member
Registered: 2007-02-06
Posts: 9

Re: Menu entry not working

If you goto:
RightClick>>Settings>>Menu Layout
You are greeted with an editor to add/delete menu items and additional menus.

When I add a menu item it doesn't appear. When I move items around, they do not change in the Desktop Menu. Even adding a "separator" does nothing.

brad

Offline

#4 2007-02-07 18:09:27

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: Menu entry not working

I had a strange menu at once after the installation but deleted the configuration files in /home/magnus/.config/xfce4/desktop and copied a new fresh menu file from /etc/xdg/xfce4/desktop  with my countries language 'menu.xml.sv'. And of cause changed the permissions with 'chmod magnus:magnus /home/magnus/.config/xfce4/desktop/menu.xml.sv'

Offline

#5 2007-02-07 20:33:30

brad
Member
Registered: 2007-02-06
Posts: 9

Re: Menu entry not working

ok.. so according to this doc: http://www.xfce.org/documentation/4.0/manuals/xfdesktop you have to manually edit menu.xml (which is a different place in gentoo than what it indicates.)

So, what the heck is the menu layout editor for?

Offline

#6 2007-02-07 21:41:54

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Menu entry not working

The menu editor is designed for editing menu and if your menu.xml file is in another location you can easily open it in the editor and uh ... edit it.

Offline

#7 2007-02-07 22:19:49

brad
Member
Registered: 2007-02-06
Posts: 9

Re: Menu entry not working

I was referring to the menu layout editor. I can tell you, it's strange that there is a menu layout editor AND a menu editor.

Offline

#8 2007-02-08 07:30:20

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Menu entry not working

Well the layout editor is not part of Xfce.

Offline

Board footer

Powered by FluxBB