Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-12 06:22:50

Genone
Member
Registered: 2007-02-12
Posts: 1

fixing z-order of panels in xfce-4.4

Hi,

I was wondering if there is a way to set the z-order of panels to a fixed value instead of the current behavior where the panel that received the last click is in the foreground. Basically I've moved the usual "bottom" panel to the top and enabled autohide for it, and in previous versions if I moved the mouse to the top of the screen it appeared on top of the taskbar, but with 4.4 if I click on the taskbar to switch apps it gets the focus and I can't get the launcher panel anymore (unless I open the "Customize panel" which disables autohide temporary).
So, is there a way to get the old behavior back (hidden config option, patch, anything)?

Offline

#2 2007-02-12 09:54:53

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: fixing z-order of panels in xfce-4.4

Nope, there is no (hidden) setting for this. There is a setting in the window manager tweaks to add all windows in the alt+tab command, so maybe this works to active the right panel... duno.

Offline

#3 2007-02-17 21:03:43

Jellybean
Member
Registered: 2007-02-17
Posts: 43

Re: fixing z-order of panels in xfce-4.4

I would like to fix this swip-swap behaviour also. Preferably, full width panels shouldn't be completely full width if another panel is in the way.

Offline

#4 2007-02-19 11:53:49

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: fixing z-order of panels in xfce-4.4

Well IIRC there is a patch for this in Bugzilla (or setting the width of the panel to a fixed % of the screen width, something like that). But it's not every easy to integrate in the framework, anyway I'll keep it in mind and when I have time I'll look into it.

Offline

Board footer

Powered by FluxBB