Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-18 10:18:57

Johnnie390
Member
From: EU
Registered: 2007-02-18
Posts: 1
Website

English

Hello all,

how do I change the standard language setting to use British English (en_GB)?? I do not want to use american English.


Regards,


J.

Offline

#2 2007-02-18 14:30:03

MagnusBerg
Member
Registered: 2004-12-17
Posts: 45

Re: English

That's not a Xfce thing. You have to change the system settings.

Offline

#3 2007-02-19 12:00:25

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: English

Set the environment variable LC_ALL="en_GB" (maybe with or without utf8) before starting the desktop.

Offline

#4 2007-02-20 16:35:25

abraxas
Member
Registered: 2007-02-18
Posts: 1

Re: English

This setting is really very system and distro-specific. If you do have a folder called '/etc/env.d/' just add a file called something like 02language and put your locale in it. Then update the environment and do a reboot  or just source

if [ -d /etc/env.d ]; then
  echo "LC_ALL=en_GB.UTF-8" >> /etc/env.d/02language
  env-update
  source /etc/profile
fi
echo $LC_ALL

that's how one would do it on a normal Gentoo system. So you have to find out how you would do that on your system if it works differently. Be sure to also have compiled the locales.
Please ask the guys from your distro about it, since it's not an Xfce issue smile

Offline

Board footer

Powered by FluxBB