Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-17 13:34:47

faabrizio
Member
Registered: 2007-02-17
Posts: 11

First login attemp failed

Hello,

I am using Xfce 4.4.0 (but I had the same problem with version 4.2.3.2). The session manager is xdm (runlevel 4). At computer startup, the first login attempt failed ; i.e. xfce splash screen shows up and after one second or so, I get back the xdm prompt for login and password. I login again and this time it works fine. It does so every time.

I search the web and the forum but could not find any hint. I don't know where to begin to understand this problem. So here I give the local xfce-session.rc, the global (/etc/...) xfce-session, and the .xsession-errors. If any one can help me, tell me where to look... any help would be greatly appreciated.

-- .xsession-errors --
Agent pid 2585

(xfce-mcs-manager:2596): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-
plugins/libxffmsettings.so cannot be opened (GModule initialization check failed
: Incorrect module version)
** Message: Querying Xkb extension
** Message: Xkb extension found
** Message: This build doesn't include support for XF86Misc extension
** Message: Querying Xkb extension
** Message: Xkb extension found

(xfce-mcs-manager:2596): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-
plugins/xftaskbar_plugin.so cannot be opened (GModule initialization check faile
d: Incorrect module version)

(xfce-mcs-manager:2596): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-
plugins/xfcalendar_plugin.so cannot be opened (GModule initialization check fail
ed: Incorrect module version)

(xfce-mcs-manager:2596): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-
plugins/xfce4-iconbox_settings.so cannot be opened (GModule initialization check
failed: Incorrect module version)

** (xfce-mcs-manager:2596): CRITICAL **: find_master: assertion `mixer_handle !=
-1' failed

** (xfce-mcs-manager:2596): WARNING **: oss: No master volume

** (xfwm4:2598): WARNING **: The display does not support the XComposite extensi
on.

** (xfwm4:2598): WARNING **: Compositing manager disabled.

-- local xfce-session.rc --
[Splash Screen]
Engine=mice

[General]
SessionName=Default
SaveOnExit=false
AutoSave=false
PromptOnLogout=false
DisableTcp=true

[Compatibility]
LaunchGnome=false
LaunchKDE=false

[Chooser]
AlwaysDisplay=false

-- global xfce-session.rc --
[...snip header...]
[General]
SessionName=Default
SessionName[de]=Standard
SessionName[ja]=æ¨æº

# Disable management of remote clients by default. The user
# has to explicitly enable this for security reasons.
DisableTcp=True


# This the default session launched by xfce4-session if the
# user hasn't saved any session yet or creates a new session.
[Failsafe Session]
Count=4
Client0_Command=xfwm4
Client0_PerScreen=False
Client1_Command=xfce4-panel
Client1_PerScreen=False
Client2_Command=Thunar,--daemon
Client2_PerScreen=False
Client3_Command=xfdesktop
Client3_PerScreen=False


# Default splash screen selection.
[Splash Screen]
Engine=mice

Fabrizio,
PS : if this is the wring forum, i am sorry, please redirect me

Offline

#2 2007-02-19 11:51:11

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: First login attemp failed

Does Xfce start when you run 'startxfce4' from tty1?

Offline

#3 2007-02-20 21:55:13

faabrizio
Member
Registered: 2007-02-17
Posts: 11

Re: First login attemp failed

It seems to work. I guess I have to have a look at xdm script and logs.

Thanks for the advice

Still, any idea would be appreciated.

Offline

#4 2007-02-21 23:17:53

faabrizio
Member
Registered: 2007-02-17
Posts: 11

Re: First login attemp failed

I find the solution. Just in case it's useful to anyone else.

.xession-errors indicated :
Agent pid 2526
_IceTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_IceTransMakeAllCOTSServerListeners: server already running
xfce4-session: Unable to establish ICE listeners: Cannot establish any listening sockets
Agent pid 2526 killed

Eventually I found on the web that it was a /tmp/.ICE-unix related errors. Problem of rights.

I added the following lines at the beginning of the rc.4 script :
rm -rf /tmp/.ICE-unix
mkdir -p -m 01777 /tmp/.ICE-unix

Works fine now.

Offline

Board footer

Powered by FluxBB