Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-03-09 00:43:36

brs
Member
Registered: 2007-03-09
Posts: 4

removable drives don't appear in Thunar or desktop

Hi,

I'm running Debian Etch with
xfdesktop4                        4.3.99.1-1
thunar                            0.4.0rc1-3
hal                               0.5.8.1-6.1

and when I insert a USB drive, no icon for it appears on the desktop or Thunar sidebar.  It is reported in /var/log/messages as sdg1, and I can use pmount /dev/sdg1 to mount it.  I noticed that hald-addon-storage doesn't seem to be polling sdg and suspect this might have something to do with it, but I'm not sure how to fix the problem.

ben@iserben390:~$ ps ax|grep hald
5548 ?        Ss     0:01 /usr/sbin/hald
5549 ?        S      0:00 hald-runner
5555 ?        S      0:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
5559 ?        S      0:00 hald-addon-keyboard: listening on /dev/input/event1
5573 ?        S      0:00 hald-addon-storage: polling /dev/sdf
5575 ?        D      0:00 hald-addon-storage: polling /dev/sde
5577 ?        S      0:00 hald-addon-storage: polling /dev/sdd
5579 ?        S      0:00 hald-addon-storage: polling /dev/sdc
5581 ?        S      0:00 hald-addon-storage: polling /dev/hdb
5583 ?        S      0:00 hald-addon-storage: polling /dev/hda
7357 pts/0    S+     0:00 grep hald

Thanks,
Ben

Offline

#2 2007-03-09 16:44:05

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: removable drives don't appear in Thunar or desktop

Put whose two lines in your /etc/apt/sources.list and you will get a real 4.4 version of Xfce and more packages to chose from.

deb http://debian.corsac.net unstable/
deb http://debian.corsac.net experimental/

Take all packages but libexo from unstable. And install libexo from experimental. That version has support for Thunar Volume Manager that automount devices.

That was the case a couple of weeks ago it's possible that libexo in unstale has support for Thunar Volume Manager now. Let us now if you try that version.

Offline

#3 2007-03-09 23:48:17

brs
Member
Registered: 2007-03-09
Posts: 4

Re: removable drives don't appear in Thunar or desktop

I did that and upgraded all packages (using Synaptic) and also installed thunar-volman.  Now, the icon appears on the desktop and in Thunar.  However, when I click on it I get this:

exo-mount: Cannot mount by HAL device UDI, because HAL support was disabled for this build

I have tried doing
   apt-get update
   apt-get -t experimental  install libexo-0.3-0
(this is the only libexo package I can find), but it tells me it is already the newest version.

dpkg -l libexo-0.3-0
...
ii  libexo-0.3-0   0.3.2-1        Library with extensions for Xfce

Is there a newer version that I'm not getting for some reason?

Thanks,
Ben

Offline

#4 2007-03-11 18:51:38

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: removable drives don't appear in Thunar or desktop

Then I installed from experimental I got version 0.3.2-2
Are you sure you didn't got the version from Debian's experimental repository???

Offline

#5 2007-03-12 18:09:02

brs
Member
Registered: 2007-03-09
Posts: 4

Re: removable drives don't appear in Thunar or desktop

I don't think so - here is my sources.list:

deb http://ftp.us.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

deb http://debian.corsac.net unstable/
deb http://debian.corsac.net experimental/


When I point my browser to http://debian.corsac.net/experimental/, I only see powerpc packages - maybe this has something to do with it?

Offline

#6 2007-03-13 09:57:37

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: removable drives don't appear in Thunar or desktop

Ask about it at the irc channel #debian-xfce@freenode They answer faster than me and I don't know that they have done with 0.3.2-2 for x86.

Offline

#7 2007-03-13 20:21:20

brs
Member
Registered: 2007-03-09
Posts: 4

Re: removable drives don't appear in Thunar or desktop

I just compiled exo-0.3.2 from source and it works now.  Thanks for the advice.

Ben

Offline

Board footer

Powered by FluxBB