Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-15 07:02:53

penguin007
Member
Registered: 2007-02-15
Posts: 4

XFCE 4.4 Fedora Core 5

Hi
I am trying to install xfce4.4 with the

xfce4-4.4.0-installer.run

I have all the package installed what is need for xfce4.4
also the package

libX11-devel

But when I try to install it i got this error:

configure: error: X Window system libraries and header files are required
!! Failed to configure libxfce4mcs, see the errors above
!! for details on the problem.

Distro: Fedora Core 5
Arch:  x86_64

Thx for your help

sry for my bad english.

Offline

#2 2007-02-15 07:38:58

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: XFCE 4.4 Fedora Core 5

You need the libx11-devel package.

Offline

#3 2007-02-15 08:04:51

penguin007
Member
Registered: 2007-02-15
Posts: 4

Re: XFCE 4.4 Fedora Core 5

Hi I know
I have installed the libX11-devel package
but it doesnt work

Offline

#4 2007-02-15 08:54:54

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: XFCE 4.4 Fedora Core 5

Then look on you system where the x11.pc file is located and add the path to this directory to the PKG_CONFIG_PATH environment variable before running the installer.

PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/X11R6/lib/pkgconfig ./xfce4-4.4.0-installer.run

for example.

Offline

#5 2007-02-15 09:31:39

penguin007
Member
Registered: 2007-02-15
Posts: 4

Re: XFCE 4.4 Fedora Core 5

ls /usr/lib64/pkgconfig/x11.pc
/usr/lib64/pkgconfig/x11.pc
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/lib64/pkgconfig ./xfce4-4.4.0-installer.run

I get the same error

Offline

#6 2007-02-22 14:42:35

ianus
Member
Registered: 2007-02-22
Posts: 1

Re: XFCE 4.4 Fedora Core 5

the problem is in the libxfce4mcs package. it is checking for X libs and headers. normally this would be libX11-devel in fc5, but if you look in the configure script, where it is checking for X you will find on line 21388 this:

# Guess where to find include files, by looking for Intrinsic.h

on fc5 systems this file is provided by libXt-devel.

i spent 3 hours g00gling around and searching for a solution until i decided to read the configure script in the libxfce4mcs package. after that, all went ok.

good luck
ianus

Offline

#7 2007-02-27 13:28:00

penguin007
Member
Registered: 2007-02-15
Posts: 4

Re: XFCE 4.4 Fedora Core 5

Hi

thanks now i have installed xfce4.4 but now xfce-goodies doesnt like because of libusb-devel i have installed it but the installer doesnt find it sad??
by

Offline

#8 2007-03-30 13:33:14

new2linux
Member
From: Milwauke, WI
Registered: 2007-03-30
Posts: 4

Re: XFCE 4.4 Fedora Core 5

create a symlink to that file in the correct place and name it what the program is looking for or just open the configure script and change the name of what it is looking for to what your Fedora Name is.


Been on Linux (Ubuntu) for a year and just love it!!!!!

Offline

Board footer

Powered by FluxBB