Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-05-14 22:25:50

justakiwi
Member
Registered: 2007-02-03
Posts: 49

How to set file associations for Thunar

Not sure if this is an xfce or Fedora issue but how do I set file associations for Thunar? At the moment it's trying to open everything in a text editor. I know I can right click and "open with" but how can I tell it to (for instance) always open .odt files with StarOffice Writer? I can't see anywhere to do this and there is nothing in the Fedora menu either - at least not that I can see.

What am I missing?

Offline

#2 2007-05-15 06:45:15

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: How to set file associations for Thunar

If you select the check box "always user this app to open this extension" when choosing a custom app, thunar should save this and use your custom application in the feature. But it's basically a .desktop file problem in startoffice. If Staroffice provides a good desktop file (in $PATH/usr/applications) with the extensions it supports, Thunar should pick this up.

Also make sure you have the shared-mime-info package installed and update the mime database by running update-mime-database.

Offline

#3 2007-05-15 07:42:33

justakiwi
Member
Registered: 2007-02-03
Posts: 49

Re: How to set file associations for Thunar

Thanks for that. I've got it working now. The only thing I haven't managed to figure out is how to tell it to open HTML files in a new tab in Opera (if it's already running) rather than open a new instance of Opera. Have you any idea how I can change that behaviour?

Offline

#4 2007-05-15 07:48:16

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: How to set file associations for Thunar

IIRC there is a setting for that in Opera...

Offline

Board footer

Powered by FluxBB