Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-01-29 00:37:01

classic
Member
Registered: 2006-09-18
Posts: 11

exo-mount with utf8

hi,

how i can tell exo-mount to mount devices with utf8 charset .

thanks .

Offline

#2 2007-08-10 21:41:23

eurof
Member
Registered: 2007-08-10
Posts: 2

Re: exo-mount with utf8

I think it is bug in exo-mount. If your filesystem is utf-8 exo-mount will mount drives incorrectly.
I think exo-mount-hal.c should be changed.

exo-mount thinks utf8 isn't a vaild option, it isn't true...
I fixed it and now it works perfectly.

at line 650:
/* process all valid mount options */
for (m = 0; device->fsoptions[m] != NULL; ++m) {
  ...
  else if (strcmp (device->fsoptions[m], "utf8") == 0)
    {
       options[n++] = g_strdup ("utf8");
     }
}

I have exo-0.3.2

Offline

#3 2007-08-11 06:15:56

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: exo-mount with utf8

Can you please fill a bug report.

Offline

#4 2007-08-11 09:41:35

eurof
Member
Registered: 2007-08-10
Posts: 2

Re: exo-mount with utf8

This bug is quite similar: http://bugzilla.xfce.org/show_bug.cgi?id=2891
The problem is same: exo-mount drop the codepage and iocharset parameters. So it is  impossible to override the kernel default setting. George Kibardin's patch solve both problem.
I don't know so much about the changes in hal daemon, but I think that exo-mount is unusable and this should be changed immediately. It affects a lot of people...
I think my modification isn't deprecated, but it only useful if use utf8 filesystem and codepage setting is correct in your kernel... Maybe the codepage problem can be solved in similar way.

Offline

Board footer

Powered by FluxBB