Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-10-25 10:39:35

corpi
Member
Registered: 2007-02-23
Posts: 3

Installing on Solaris 10 x86

Hi all,

    I am trying to install xfce in my solaris10x86.

     I have used the "./xfce4-4.4.1-installer.run" script, and this appear to run fine:

Xfce GTK+ engine and themes
Running configure... done
Running make all... done
Running make install... done
Cleaning up... done
Xfce Icon Theme
Running configure... done
Running make all... done
Running make install... done
Cleaning up... done

But with the xfce utility library:

Xfce Utility Library
Running configure... done
Running make all... failed


The error log saids:

cc -I/usr/local/include -I/usr/include -I/usr/include -O2 -pipe -DG_DISABLE_CAST_CHECKS -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -o .libs/xfce4-kiosk-query xfce4_kiosk_query-main.o  -L/usr/lib ../libxfce4util/.libs/libxfce4util.so -L/opt/csw/lib -lgobject-2.0 -lglib-2.0 -lintl  -R/usr/local/lib
Undefined            first referenced
symbol                  in file
g_slice_free1                       ../libxfce4util/.libs/libxfce4util.so
g_slice_alloc                       ../libxfce4util/.libs/libxfce4util.so
g_intern_static_string              ../libxfce4util/.libs/libxfce4util.so
ld: fatal: Symbol referencing errors. No output written to .libs/xfce4-kiosk-query
collect2: ld returned 1 exit status
gmake[2]: *** [xfce4-kiosk-query] Error 1
gmake[2]: Leaving directory `/tmp/selfgz5743/libxfce4util/xfce4-kiosk-query'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/tmp/selfgz5743/libxfce4util'
gmake: *** [all] Error 2
!! Failed to build libxfce4util, see the errors above
!! for details on the problem.


What could be the problem, and how can I solved it??


Thats a lot for all your help

Offline

#2 2007-10-26 14:45:30

omphile
Member
Registered: 2007-10-26
Posts: 2

Re: Installing on Solaris 10 x86

you may want to save yourself compile  headaches and download packages from opensolaris

http://dlc.sun.com/osol/xfce/downloads/current/x86/

Offline

#3 2007-10-29 08:40:03

corpi
Member
Registered: 2007-02-23
Posts: 3

Re: Installing on Solaris 10 x86

I have tried, but don't work sad

this only work to solaris express, and I have 5.10 version ...

thanks

Offline

#4 2007-11-18 14:06:52

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Installing on Solaris 10 x86

You might have 2 glibs on you pc, and linking agains the old one. Make sure you compile and link agains Glib 2.10+

Offline

#5 2007-12-10 10:56:51

omphile
Member
Registered: 2007-10-26
Posts: 2

Re: Installing on Solaris 10 x86

i just compiled 4.4.2 on solaris sparc. compiled the
tarball from source. grabbed the latest dependencies
from blastwave.org. my enviroment

PATH=/opt/csw/bin:/opt/csw/sbin:/usr/sfw/bin:/usr/bin:/sbin:/usr/sbin:/data/dev/ SUNWspro/bin:/data/dev/netbeans/bin:/usr/ccs/bin:/usr/dt/bin:/usr/openwin/bin:/u sr/sfw/bin:$EPATH/bin
LDFLAGS="-L/opt/csw/lib,-L/usr/sfw/lib,-R/opt/csw/lib,-R/usr/sfw/lib"
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/opt/csw/lib/pkgconfig
CCDIR=/opt/csw/bin
CC=${CCDIR}/gcc
CXX=${CCDIR}/g++

alias tar='gtar'
alias make='gmake'


but the packages from opensolaris should work. just make usre you install other dependenies like SUNWpcre etc.
it worked for me.

Offline

#6 2010-03-11 19:37:38

natural
Member
Registered: 2009-09-28
Posts: 7

Re: Installing on Solaris 10 x86

Any chance I could get the binaries from you?
My email is naturerunner@yahoo.com.

Thanks in advance!
Roger

omphile wrote:

i just compiled 4.4.2 on solaris sparc. compiled the
tarball from source. grabbed the latest dependencies
from blastwave.org. my enviroment

PATH=/opt/csw/bin:/opt/csw/sbin:/usr/sfw/bin:/usr/bin:/sbin:/usr/sbin:/data/dev/ SUNWspro/bin:/data/dev/netbeans/bin:/usr/ccs/bin:/usr/dt/bin:/usr/openwin/bin:/u sr/sfw/bin:$EPATH/bin
LDFLAGS="-L/opt/csw/lib,-L/usr/sfw/lib,-R/opt/csw/lib,-R/usr/sfw/lib"
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/opt/csw/lib/pkgconfig
CCDIR=/opt/csw/bin
CC=${CCDIR}/gcc
CXX=${CCDIR}/g++

alias tar='gtar'
alias make='gmake'


but the packages from opensolaris should work. just make usre you install other dependenies like SUNWpcre etc.
it worked for me.

Offline

Board footer

Powered by FluxBB